Intermittent robocop TEST-UNEXPECTED-FAIL | testNewTab | Checking tab closed - number of tabs now 2

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({intermittent-failure})

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Android Tegra 250 mozilla-inbound opt test robocop on 2012-08-06 15:18:17 PDT for push a218e9b11bc5

slave: tegra-236

https://tbpl.mozilla.org/php/getParsedLog.php?id=14170107&tree=Mozilla-Inbound

{
6 INFO TEST-PASS | testNewTab | Checking tab closed - number of tabs now 2
7 INFO TEST-UNEXPECTED-FAIL | testNewTab | Checking tab closed - number of tabs now 2
Exception caught during test!
junit.framework.AssertionFailedError: 7 INFO TEST-UNEXPECTED-FAIL | testNewTab | Checking tab closed - number of tabs now 2
	at junit.framework.Assert.fail(Assert.java:47)
	at org.mozilla.fennec.FennecMochitestAssert._logMochitestResult(FennecMochitestAssert.java:107)
	at org.mozilla.fennec.FennecMochitestAssert.ok(FennecMochitestAssert.java:137)
	at org.mozilla.fennec.tests.testNewTab.closeTabs(testNewTab.java:138)
	at org.mozilla.fennec.tests.testNewTab.testNewTab(testNewTab.java:57)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:521)
	at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:204)
	at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:194)
	at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:186)
	at org.mozilla.fennec.tests.BaseTest.runTest(BaseTest.java:94)
	at junit.framework.TestCase.runBare(TestCase.java:127)
	at junit.framework.TestResult$1.protect(TestResult.java:106)
	at junit.framework.TestResult.runProtected(TestResult.java:124)
	at junit.framework.TestResult.run(TestResult.java:109)
	at junit.framework.TestCase.run(TestCase.java:118)
	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:169)
	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:154)
	at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:520)
	at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1447)
8 INFO TEST-UNEXPECTED-FAIL | testNewTab | Exception caught - junit.framework.AssertionFailedError: 7 INFO TEST-UNEXPECTED-FAIL | testNewTab | Checking tab closed - number of tabs now 2
}
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Whiteboard: [orange]
I cannot reproduce and this doesn't seem to be happening in test runs any more. Please re-open if it recurs.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.