Last Comment Bug 780973 - IonMonkey: Try to enter outer loops rather than inner loops via OSR
: IonMonkey: Try to enter outer loops rather than inner loops via OSR
Status: RESOLVED FIXED
[ion:p1:fx18]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Jan de Mooij [:jandem]
: general
Mentors:
: 779860 (view as bug list)
Depends on:
Blocks: IonSpeed 777572
  Show dependency treegraph
 
Reported: 2012-08-07 12:53 PDT by Jan de Mooij [:jandem]
Modified: 2012-08-09 04:58 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (15.64 KB, patch)
2012-08-07 12:53 PDT, Jan de Mooij [:jandem]
dvander: review+
bhackett1024: review+
Details | Diff | Review

Description Jan de Mooij [:jandem] 2012-08-07 12:53:54 PDT
Created attachment 649764 [details] [diff] [review]
Patch

This patch changes the recompile checks inserted by JM and Ion to use a slightly higher threshold for inner loops. The result is that we are more likely to enter outer loops instead of inner loops via OSR.

This closes about half the gap with JM+TI on ss-fannkuch (the rest seems to be compilation time, we are now faster than JM+TI on the modified benchmark in bug 777572), fixes the micro-benchmark in bug 779860 comment 0 and is a small v8-richards win.
Comment 1 Jan de Mooij [:jandem] 2012-08-08 09:55:25 PDT
https://hg.mozilla.org/projects/ionmonkey/rev/5e461fb2250a
Comment 2 Jan de Mooij [:jandem] 2012-08-09 04:58:13 PDT
*** Bug 779860 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.