Last Comment Bug 781102 - Continue with debugger initialization after the editor finished loading
: Continue with debugger initialization after the editor finished loading
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: 12 Branch
: All All
: P3 normal (vote)
: Firefox 17
Assigned To: Victor Porof [:vporof][:vp]
:
Mentors:
Depends on:
Blocks: 774788
  Show dependency treegraph
 
Reported: 2012-08-08 00:26 PDT by Victor Porof [:vporof][:vp]
Modified: 2012-08-09 11:50 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (2.23 KB, patch)
2012-08-08 00:34 PDT, Victor Porof [:vporof][:vp]
rcampbell: review+
Details | Diff | Splinter Review

Description Victor Porof [:vporof][:vp] 2012-08-08 00:26:55 PDT
We currently have a racing condition between the editor and the client finishing initialization. I suspect this is the cause for a lot of "aTab = null" and "undefined editor._view" happening in tests.
Comment 1 Victor Porof [:vporof][:vp] 2012-08-08 00:34:22 PDT
Created attachment 649983 [details] [diff] [review]
v1
Comment 2 Rob Campbell [:rc] (:robcee) 2012-08-08 13:26:07 PDT
Comment on attachment 649983 [details] [diff] [review]
v1

aright.
Comment 3 Victor Porof [:vporof][:vp] 2012-08-08 14:48:35 PDT
https://hg.mozilla.org/integration/fx-team/rev/ff74f6bac60d
Comment 4 Tim Taubert [:ttaubert] 2012-08-09 11:50:46 PDT
https://hg.mozilla.org/mozilla-central/rev/ff74f6bac60d

Note You need to log in before you can comment on or make changes to this bug.