Last Comment Bug 781128 - Multiple identical talos jobs scheduled even though no re-triggers requested
: Multiple identical talos jobs scheduled even though no re-triggers requested
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- major (vote)
: mozilla17
Assigned To: Mike Hommey [:glandium]
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 04:01 PDT by Ed Morley [:emorley]
Modified: 2012-08-08 18:25 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix application.ini dependencies after bug 767839 (813 bytes, patch)
2012-08-08 09:50 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2012-08-08 04:01:39 PDT
On:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=9428d40e8ead

Some of the talos runs have three sets of results.

My first thought that was someone had re-triggered them, but there is only one entry for each on the self-serve page.

eg compare:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=9428d40e8ead&jobname=Rev4%20MacOSX%20Lion%2010.7%20mozilla-inbound%20talos%20dirty

with
https://secure.pub.build.mozilla.org/buildapi/self-serve/mozilla-inbound/rev/9428d40e8ead + filter builds on 'Rev4 MacOSX Lion 10.7 mozilla-inbound talos dirty'
Comment 1 Phil Ringnalda (:philor) 2012-08-08 09:21:40 PDT
https://tbpl.mozilla.org/php/getParsedLog.php?id=14228341&tree=Mozilla-Inbound and https://tbpl.mozilla.org/php/getParsedLog.php?id=14228371&tree=Mozilla-Inbound are particularly nice, since it's now trying to do 10.5 talos.
Comment 2 Chris AtLee [:catlee] 2012-08-08 09:32:56 PDT
so the test machine claims that
http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-macosx64/1344405509/firefox-17.0a1.en-US.mac.dmg

has revision 9428d40e8ead (from application.ini), but the file came from revision fda1cd4d7dba
Comment 3 cmtalbert 2012-08-08 09:44:42 PDT
Joel & Jeads, this issue is going to play havoc with datazilla and might be a cause behind why we're "missing" changes when we compare them to the pushlog in datazilla. It will of course depend on how long this has been going on.
Comment 4 Ed Morley [:emorley] 2012-08-08 09:46:37 PDT
Closed m-c and inbound per #build
Comment 5 Mike Hommey [:glandium] 2012-08-08 09:50:13 PDT
Created attachment 650184 [details] [diff] [review]
Fix application.ini dependencies after bug 767839
Comment 6 Ted Mielczarek [:ted.mielczarek] 2012-08-08 09:52:13 PDT
Comment on attachment 650184 [details] [diff] [review]
Fix application.ini dependencies after bug 767839

Review of attachment 650184 [details] [diff] [review]:
-----------------------------------------------------------------

Exciting stuff.
Comment 8 Phil Ringnalda (:philor) 2012-08-08 10:36:24 PDT
Reopened the trees since pushes on top are the easy way to tell it's fixed - comment 1 must be something different, which we hope a scheduler restart cured.
Comment 9 Ryan VanderMeulen [:RyanVM] 2012-08-08 18:25:36 PDT
https://hg.mozilla.org/mozilla-central/rev/4baae73d53c0

Note You need to log in before you can comment on or make changes to this bug.