Include In-Reply-To header when sending replies

RESOLVED FIXED in Future

Status

--
enhancement
RESOLVED FIXED
18 years ago
5 years ago

People

(Reporter: mozilla.org, Assigned: jgmyers)

Tracking

Trunk
Future

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Mozilla should add the In-Reply-To header to replies as specified in RFC 2822:

http://www.ietf.org/rfc/rfc2822.txt
(Reporter)

Updated

18 years ago
Keywords: correctness

Comment 1

18 years ago
I agree emphatically.

I must say that my expeience with bug 8965 makes me think this won't happen any
time soon.
accepting
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 3

18 years ago
tenthumbs - that's nonsense - bug 8965 was fixed, and the remaining argument was
what to do about clients that generated contradictory in-reply-to and
x-references headers, i.e. how to deal with broken clients. I fail to see what
that has to do with generating an in-reply-to header.

Comment 4

18 years ago
Is this a dup of bug #31314?

*** This bug has been marked as a duplicate of 31314 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

17 years ago
This is not a duplicate of bug 31314. That bug report is asking for a feature in
Bugzilla. This bug report is asking for a feature in the Mozilla mail/news client.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
oops, my mistake.
Status: REOPENED → ASSIGNED
Target Milestone: --- → Future

Updated

17 years ago
Summary: support In-Reply-To header in replies → Include In-Reply-To header when sending replies

Comment 8

17 years ago
*** Bug 129934 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
Also there should be an easy way to add/edit custom headers to your mail/news
message such as:

In-Reply-To:
References:
Supercedes:

or any header a user wishes to add/edit.

Comment 10

17 years ago
Kelly: that's bug #16925 (which is marked fixed BTW). This is about generating
the In-Reply-To header automatically when replying.
(Assignee)

Comment 11

16 years ago
Created attachment 101604 [details] [diff] [review]
Proposed fix
(Assignee)

Comment 12

16 years ago
Taking bug.
Assignee: ducarroz → jgmyers
Status: ASSIGNED → NEW
Comment on attachment 101604 [details] [diff] [review]
Proposed fix

Looks good, R=ducarroz
Attachment #101604 - Flags: review+

Comment 14

16 years ago
Comment on attachment 101604 [details] [diff] [review]
Proposed fix

sr=bienvenu
Attachment #101604 - Flags: superreview+
(Reporter)

Comment 15

16 years ago
Will this patch make it into mozilla 1.2?
Keywords: mozilla1.2
(Assignee)

Comment 16

16 years ago
Fixed on trunk.
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → FIXED

Comment 17

16 years ago
I have seen a problem which would be caused by this fix. I filed it Bug 173645.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.