Last Comment Bug 781269 - Blocklist Search By Image (by Google) due to very poor performance
: Blocklist Search By Image (by Google) due to very poor performance
Status: RESOLVED FIXED
: qawanted
Product: Toolkit
Classification: Components
Component: Blocklisting (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Jorge Villalobos [:jorgev]
: juan becerra [:juanb]
Mentors:
https://addons.mozilla.org/firefox/ad...
Depends on:
Blocks: 777266
  Show dependency treegraph
 
Reported: 2012-08-08 11:09 PDT by Jorge Villalobos [:jorgev]
Modified: 2016-03-07 15:30 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jorge Villalobos [:jorgev] 2012-08-08 11:09:18 PDT
The Search By Image (by Google) extension causes very high CPU utilization during regular browsing, often damaging user experience significantly, in a way that is very difficult to associate with the extension.

We gave the developers advice and sufficient time to correct the issue (see bug 777266), but so far only minor performance fixes have been issued. Since its usage stats are worrying, we have decided to go ahead with the block, which will be pushed live this Friday.
Comment 1 Jorge Villalobos [:jorgev] 2012-08-08 11:14:03 PDT
The block has been staged now:
https://addons-dev.allizom.org/en-US/firefox/blocked/i117
Comment 2 Jorge Villalobos [:jorgev] 2012-08-10 08:51:42 PDT
Blocked:

https://addons.mozilla.org/en-US/firefox/blocked/i117
Comment 3 S2 2012-08-10 16:51:58 PDT
I remember using an older version of it but the cpu was just fine, then later, i updated it to 1.0.6.  At 1st, I thought it was my comp or Firefox using up to 50% CPU but it was Google's newer add-on, 1.0.6.  Firefox was slow overall.  Please tell Google about this.

The 1.0.4 is the safe version.  Test it out.  ;]

Note You need to log in before you can comment on or make changes to this bug.