Last Comment Bug 781307 - Remove make rules from services/
: Remove make rules from services/
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla17
Assigned To: Gregory Szorc [:gps]
:
Mentors:
Depends on:
Blocks: nomakerules
  Show dependency treegraph
 
Reported: 2012-08-08 12:11 PDT by Gregory Szorc [:gps]
Modified: 2012-08-13 10:57 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Use generic rules, v1 (5.16 KB, patch)
2012-08-08 12:11 PDT, Gregory Szorc [:gps]
mh+mozilla: review+
Details | Diff | Splinter Review

Description Gregory Szorc [:gps] 2012-08-08 12:11:00 PDT
Created attachment 650245 [details] [diff] [review]
Use generic rules, v1

This is like bug 759487 but for all other Makefile.in's in services/.

services/common/Makefile.in still has some rules for functionality I added a few months back to run some standalone test servers. But, the rules come after rules.mk, so I don't think it will be a problem.

The new generic install rule rocks!
Comment 1 Mike Hommey [:glandium] 2012-08-08 23:19:33 PDT
Comment on attachment 650245 [details] [diff] [review]
Use generic rules, v1

Review of attachment 650245 [details] [diff] [review]:
-----------------------------------------------------------------

::: services/aitc/Makefile.in
@@ +23,5 @@
>    $(NULL)
>  
>  PREF_JS_EXPORTS = $(srcdir)/services-aitc.js
>  
> +AITC_MODULE_FILES := $(foreach module,$(aitc_modules),modules/$(module))

$(addprefix modules/,$(aitc_modules))

@@ +24,5 @@
>  
>  PREF_JS_EXPORTS = $(srcdir)/services-aitc.js
>  
> +AITC_MODULE_FILES := $(foreach module,$(aitc_modules),modules/$(module))
> +AITC_MODULE_DEST := $(FINAL_TARGET)/modules/services-aitc

You don't need config.mk if you use =.

::: services/common/Makefile.in
@@ +38,1 @@
>  TESTING_JS_MODULES := $(foreach file,$(testing_modules),modules-testing/$(file))

Can you change this to use addprefix while you're here?
Comment 2 Gregory Szorc [:gps] 2012-08-09 12:57:50 PDT
*** Bug 781498 has been marked as a duplicate of this bug. ***
Comment 4 Gregory Szorc [:gps] 2012-08-13 10:57:30 PDT
https://hg.mozilla.org/mozilla-central/rev/f9452e60f4ad

Note You need to log in before you can comment on or make changes to this bug.