###!!! ASSERTION: OnStopDecode called multiple times.: '!(mState & onStopDecode)', file

RESOLVED INVALID

Status

()

Core
ImageLib
P2
normal
RESOLVED INVALID
17 years ago
7 years ago

People

(Reporter: timeless, Unassigned)

Tracking

({assertion})

Trunk
Future
assertion
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
SunOS 5.7 Generic_106541-15 sun4u sparc SUNW,Ultra-2
mozilla cvs build for xlib from this morning.

steps to reproduce run choffman's browser buster, this assertion happens for 
choffman urls: 66, 69, 86, 91, and 100.
(Reporter)

Comment 1

17 years ago
Created attachment 32601 [details]
snipets from running choffman browser buster.

Comment 2

17 years ago
can you please post at least 1 real url that points to a page where you see 
this?

Comment 3

17 years ago
I see this consistenly on NT at http://www.kcbs.com

I'll attach a stack.
OS: Solaris → All
Hardware: Sun → All

Comment 4

17 years ago
Created attachment 32699 [details]
assertion stack

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.1

Comment 5

17 years ago
works for me today.. I think that saari fixed this bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 6

17 years ago
Saw this assertion on peterl's build from yesterday (06/04/01), reopening
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 7

17 years ago
argh.  where?
Target Milestone: mozilla0.9.1 → mozilla0.9.2

Comment 9

17 years ago
Yeah. I still see this on that URL. I didn't realize this had been closed.

Updated

17 years ago
Priority: -- → P2

Comment 10

17 years ago
another URL that's showing this is http://sinfest.net/ (no, it's NOT what you
think it is... ;)  

###!!! ASSERTION: OnStopDecode called multiple times.: '!(mState &
onStopDecode)', file imgRequest.cpp, line 512
###!!! Break: at file imgRequest.cpp, line 512
###!!! ASSERTION: OnStopDecode called multiple times.: '!(mState &
onStopDecode)', file imgRequest.cpp, line 512
###!!! Break: at file imgRequest.cpp, line 512
###!!! ASSERTION: Multiple GetIIDs function for the same nsDOMClassInfoID:
'sClassInfoData[aID].mGetIIDsFptr == aGetIIDsFptr', file nsDOMClassInfo.cpp,
line 993
###!!! Break: at file nsDOMClassInfo.cpp, line 993

Comment 11

17 years ago
Created attachment 38367 [details]
current stack, from linux, via XPCOM_DEBUG_BREAK instead of gdb

Comment 12

17 years ago
0.9.3
Status: REOPENED → ASSIGNED
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Comment 14

17 years ago
-> 0.9.4
Target Milestone: mozilla0.9.3 → mozilla0.9.4
(Reporter)

Updated

17 years ago
Blocks: 79119

Updated

17 years ago
Target Milestone: mozilla0.9.4 → mozilla0.9.5

Updated

17 years ago
Target Milestone: mozilla0.9.5 → Future

Comment 15

17 years ago
I believe I fixed this when I checked in a patch to handle GIF errors properly.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 16

17 years ago
*** Bug 94241 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

17 years ago
Keywords: assertion

Comment 17

17 years ago
Using Mozilla 0.9.9 Gecko 20020304 debug build, the assert happens when loading:

http://sinfest.net/ (2nd assert; after nsCookieService assert)
http://www.monsanto.com

From bug 94241:

http://www.airliners.net/search/photo.search

Other urls in this bug work fine.

Comment 18

17 years ago
reopening as some urls cause the assert (see above)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 19

16 years ago
I've had this assertion occur when I wouldn't let an image fully load (I'd go to
another page before it finished loading).  Then, when going back to the page,
the assertion would fire (after the image was fully loaded)

Updated

16 years ago
Blocks: 160540
I see these assertions on http://www.keskisuomalainen.net as well. Beware,
because of another bug the product will stop handling most events meaning you
will have to kill it.

Comment 21

16 years ago
*** Bug 193472 has been marked as a duplicate of this bug. ***

Comment 22

15 years ago
http://i.real.com/pics/real/main/curve.gif from http://www.real.com is an
example (the cause here is a corrupt image--it has ~600K of arbitrary data after
the ~1.4K image). The problem is generally that
http://lxr.mozilla.org/seamonkey/source/modules/libpr0n/decoders/gif/GIF2.cpp#996
(gif_write) gets called more than once with a gif_done status.

Perhaps gif_write should return failure if it gets entered again after gif_done;
however, that's a guess, since I don't know this code.

Updated

11 years ago
Assignee: pavlov → nobody
Status: REOPENED → NEW
QA Contact: tpreston → imagelib
This assert is no longer in the codebase.
Status: NEW → RESOLVED
Last Resolved: 17 years ago7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.