Last Comment Bug 781390 - Make barrier verifier testing work better with the methodjit
: Make barrier verifier testing work better with the methodjit
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla17
Assigned To: Bill McCloskey (:billm)
: general
Mentors:
Depends on: 783421
Blocks: 774859
  Show dependency treegraph
 
Reported: 2012-08-08 17:17 PDT by Bill McCloskey (:billm)
Modified: 2012-09-28 16:05 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (21.29 KB, patch)
2012-08-08 17:17 PDT, Bill McCloskey (:billm)
bhackett1024: review+
Details | Diff | Splinter Review

Description Bill McCloskey (:billm) 2012-08-08 17:17:42 PDT
Created attachment 650380 [details] [diff] [review]
patch

While looking at bug 774859, I was trying to write a test case using the write barrier verifier and the methodjit. However, it turns out to be almost impossible to do that. We're supposed to invoke the operation callback in the methodjit when running with gczeal(4). However, each time we call StartVerifyPreBarriers, it calls setNeedsBarrier, which causes us to return to the interpreter.

This patch makes testing a little easier by always compiling with barriers when gczeal==4. That way we don't have to return to the interpreter each time we do Start/EndVerifyPreBarriers.
Comment 2 Ryan VanderMeulen [:RyanVM] 2012-08-15 18:45:06 PDT
https://hg.mozilla.org/mozilla-central/rev/07f21ec5d516
Comment 3 Ian Neal 2012-08-27 02:37:10 PDT
Looks like this (or a subset of) needs to be landed on mozilla-aurora to prevent bustage by the landing of the patch from bug 774859

Note You need to log in before you can comment on or make changes to this bug.