Last Comment Bug 781676 - java.lang.NullPointerException: at org.mozilla.gecko.gfx.LayerView.onTouchEvent(LayerView.java) at com.android.internal.policy.impl.PhoneWindow$DecorView.superDispatchTouchEvent(PhoneWindow.java)
: java.lang.NullPointerException: at org.mozilla.gecko.gfx.LayerView.onTouchEve...
Status: RESOLVED FIXED
[native-crash]
: crash, regression
Product: Firefox for Android
Classification: Client Software
Component: Graphics, Panning and Zooming (show other bugs)
: 16 Branch
: ARM Android
: -- critical (vote)
: Firefox 17
Assigned To: Kartikaya Gupta (email:kats@mozilla.com)
:
Mentors:
Depends on:
Blocks: black-jellybean
  Show dependency treegraph
 
Reported: 2012-08-09 15:25 PDT by Scoobidiver (away)
Modified: 2012-08-13 11:21 PDT (History)
2 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
affected
fixed
fixed


Attachments
Patch (1.46 KB, patch)
2012-08-10 13:03 PDT, Kartikaya Gupta (email:kats@mozilla.com)
sriram.mozilla: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
lukasblakk+bugs: approval‑mozilla‑beta-
Details | Diff | Review

Description Scoobidiver (away) 2012-08-09 15:25:45 PDT
There are one crash in 16.0a2/20120807 and one in 17.0a1/20120809: bp-b5ecd2f3-ef68-4174-b9c7-6ee4f2120809.

java.lang.NullPointerException
	at org.mozilla.gecko.gfx.LayerView.onTouchEvent(LayerView.java:117)
	at android.view.View.dispatchTouchEvent(View.java:5545)
	at android.view.ViewGroup.dispatchTransformedTouchEvent(ViewGroup.java:1951)
	at android.view.ViewGroup.dispatchTouchEvent(ViewGroup.java:1712)
	at android.view.ViewGroup.dispatchTransformedTouchEvent(ViewGroup.java:1957)
	at android.view.ViewGroup.dispatchTouchEvent(ViewGroup.java:1684)
	at android.view.ViewGroup.dispatchTransformedTouchEvent(ViewGroup.java:1957)
	at android.view.ViewGroup.dispatchTouchEvent(ViewGroup.java:1684)
	at android.view.ViewGroup.dispatchTransformedTouchEvent(ViewGroup.java:1957)
	at android.view.ViewGroup.dispatchTouchEvent(ViewGroup.java:1684)
	at android.view.ViewGroup.dispatchTransformedTouchEvent(ViewGroup.java:1957)
	at android.view.ViewGroup.dispatchTouchEvent(ViewGroup.java:1684)
	at android.view.ViewGroup.dispatchTransformedTouchEvent(ViewGroup.java:1957)
	at android.view.ViewGroup.dispatchTouchEvent(ViewGroup.java:1684)
	at android.view.ViewGroup.dispatchTransformedTouchEvent(ViewGroup.java:1957)
	at android.view.ViewGroup.dispatchTouchEvent(ViewGroup.java:1684)
	at com.android.internal.policy.impl.PhoneWindow$DecorView.superDispatchTouchEvent(PhoneWindow.java:1912)
	at com.android.internal.policy.impl.PhoneWindow.superDispatchTouchEvent(PhoneWindow.java:1371)
	at android.app.Activity.dispatchTouchEvent(Activity.java:2364)
	at com.android.internal.policy.impl.PhoneWindow$DecorView.dispatchTouchEvent(PhoneWindow.java:1860)
	at android.view.View.dispatchPointerEvent(View.java:5725)
	at android.view.ViewRootImpl.deliverPointerEvent(ViewRootImpl.java:2890)
	at android.view.ViewRootImpl.handleMessage(ViewRootImpl.java:2466)
	at android.view.ViewRootImpl.processInputEvents(ViewRootImpl.java:845)
	at android.view.ViewRootImpl.handleMessage(ViewRootImpl.java:2475)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:4575)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:789)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:556)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+at+org.mozilla.gecko.gfx.LayerView.onTouchEvent%28LayerView.java%29
Comment 1 Kartikaya Gupta (email:kats@mozilla.com) 2012-08-10 13:02:40 PDT
Regression from bug 770047. Potential NPE if you touch the screen before gecko is fully initialized. Patch coming shortly.
Comment 2 Kartikaya Gupta (email:kats@mozilla.com) 2012-08-10 13:03:51 PDT
Created attachment 650983 [details] [diff] [review]
Patch
Comment 3 Sriram Ramasubramanian [:sriram] 2012-08-10 13:04:47 PDT
Comment on attachment 650983 [details] [diff] [review]
Patch

Review of attachment 650983 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me.
Comment 4 Kartikaya Gupta (email:kats@mozilla.com) 2012-08-10 13:17:37 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/20299820ca66
Comment 5 Kartikaya Gupta (email:kats@mozilla.com) 2012-08-10 13:21:30 PDT
Comment on attachment 650983 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 770047
User impact if declined: possible crash if touch events are delivered during startup. seems to be very rare according to crash-stats
Testing completed (on m-c, etc.): unable to repro, so unable to test
Risk to taking this patch (and alternatives if risky): mobile only, low-risk patch
String or UUID changes made by this patch: none
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-08-11 19:55:23 PDT
https://hg.mozilla.org/mozilla-central/rev/20299820ca66
Comment 7 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-13 11:03:17 PDT
Comment on attachment 650983 [details] [diff] [review]
Patch

Since this is rare and not possible to test I'm only approving for Aurora so we can continue to collect crash data there, but not going to take the risk of landing this to Beta so late in the cycle.
Comment 8 Kartikaya Gupta (email:kats@mozilla.com) 2012-08-13 11:21:49 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/487a4d3f98aa

Note You need to log in before you can comment on or make changes to this bug.