Last Comment Bug 781679 - Assert that we do not destroy the layer manager while in the middle of painting
: Assert that we do not destroy the layer manager while in the middle of painting
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics: Layers (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla17
Assigned To: Joe Drew (not getting mail)
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-09 15:42 PDT by Joe Drew (not getting mail)
Modified: 2012-08-16 06:19 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
assert that we're not in the middle of a transaction when switching layer managers (9.79 KB, patch)
2012-08-13 15:09 PDT, Joe Drew (not getting mail)
matt.woodrow: review+
Details | Diff | Splinter Review

Description Joe Drew (not getting mail) 2012-08-09 15:42:40 PDT
Bug 773097 was caused by switching layer managers while in the middle of painting. We should set a bit when we start painting, and unset it after we're done, and then assert that the bit is false whenever we're changing layer managers.
Comment 1 Joe Drew (not getting mail) 2012-08-13 15:09:52 PDT
Created attachment 651542 [details] [diff] [review]
assert that we're not in the middle of a transaction when switching layer managers

Haven't been able to test this yet, because I didn't have a debug build on this Windows machine, but I believe it would have caught the bug.
Comment 2 Joe Drew (not getting mail) 2012-08-14 13:13:46 PDT
This patch does, indeed, work.
Comment 3 Joe Drew (not getting mail) 2012-08-15 14:57:14 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/5c8fcc4cc760
Comment 4 Ed Morley [:emorley] 2012-08-16 06:19:01 PDT
https://hg.mozilla.org/mozilla-central/rev/5c8fcc4cc760

Note You need to log in before you can comment on or make changes to this bug.