Last Comment Bug 781692 - [b2g-bluetooth] Make BluetoothAdapter property setting functions always fire a DOMRequest
: [b2g-bluetooth] Make BluetoothAdapter property setting functions always fire ...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla17
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: b2g-bluetooth
  Show dependency treegraph
 
Reported: 2012-08-09 16:26 PDT by Kyle Machulis [:kmachulis] [:qdot]
Modified: 2012-10-22 12:22 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments
v1: Actually fire DOMRequests for Set* functions even when value is the same in BluetoothAdapter (4.11 KB, patch)
2012-08-09 17:00 PDT, Kyle Machulis [:kmachulis] [:qdot]
echou: review+
Details | Diff | Review
FINAL: Actually fire DOMRequests for Set* functions even when value is the same in BluetoothAdapter (17.71 KB, patch)
2012-08-13 15:49 PDT, Kyle Machulis [:kmachulis] [:qdot]
no flags Details | Diff | Review

Description Kyle Machulis [:kmachulis] [:qdot] 2012-08-09 16:26:06 PDT
In BluetoothAdapter, if a Set* call is made and the member being set is already equal to the requested value, the function will return NS_OK instead of filling in and returning a DOMRequest. For sake of consistency, all these functions should always fire DOM requests.
Comment 1 Kyle Machulis [:kmachulis] [:qdot] 2012-08-09 16:26:49 PDT
For blocking-basecamp: This needs to be fixed so we don't have to check edge cases in gaia. Should be a fairly quick fix.
Comment 2 Kyle Machulis [:kmachulis] [:qdot] 2012-08-09 17:00:35 PDT
Created attachment 650726 [details] [diff] [review]
v1: Actually fire DOMRequests for Set* functions even when value is the same in BluetoothAdapter
Comment 3 Eric Chou [:ericchou] [:echou] 2012-08-09 19:49:26 PDT
Comment on attachment 650726 [details] [diff] [review]
v1: Actually fire DOMRequests for Set* functions even when value is the same in BluetoothAdapter

Looks good to me. Since we're going to remove GetProperties(), class GetPropertiesTask will not be called anywhere. Please check if it can be removed as well.
Comment 4 Jonas Sicking (:sicking) PTO Until July 5th 2012-08-10 09:14:36 PDT
I actually think this is a nice-to-have unless we find that there is actual gaia functionality breaking over this.

That said, feel free to land this anyway.
Comment 5 Kyle Machulis [:kmachulis] [:qdot] 2012-08-13 15:49:06 PDT
Created attachment 651558 [details] [diff] [review]
FINAL: Actually fire DOMRequests for Set* functions even when value is the same in BluetoothAdapter

Removed GetPropTask
Comment 6 Kyle Machulis [:kmachulis] [:qdot] 2012-08-13 17:58:31 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/4b26b044d57d
Comment 7 Ed Morley [:emorley] 2012-08-14 06:00:25 PDT
https://hg.mozilla.org/mozilla-central/rev/4b26b044d57d

Note You need to log in before you can comment on or make changes to this bug.