[ia] Article listing page with l10n

RESOLVED FIXED in 2012.17

Status

support.mozilla.org
Knowledge Base Software
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: rrosario, Assigned: rrosario)

Tracking

unspecified
2012.17

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=user c=wiki p=2)

Attachments

(6 attachments)

(Assignee)

Description

5 years ago
We need to add the l10n specific features to the article listing page. All localized articles will be listed above non localized articles and there will be some separation and maybe a message for recruiting more localizers.

Bram will provide a mockup.

See bug 762255 for the latest design

Comment 1

5 years ago
For the minimum translation to happen, all topic names and interface text strings need to be available in a local language.

Given that:
1. We have narrowed the topic names down to a controlled set
2. Most locales have at least the interface text translated already

It should hopefully not be a lot of work for the locale leaders to translate these.

The minimum requirement for all locale leader is to translate:
1. Navigation menu text
2. Names of non-KB pages (top page, search, ask a question, etc.)
3. Names of topics

There are a lot of term overlaps, as well, so they can translate one topic and have it be applied on many pages.

Comment 2

5 years ago
Created attachment 650794 [details]
l10n homepage

Next, I will upload the areas that will need to be translated by each locale in order to make this work.

Comment 3

5 years ago
Created attachment 650796 [details]
l10n homepage - with notes

In order to get the homepage in working order, localizers would need to translate:
* Everything on the header (excluding Tabzilla)
* Navigation items (used as a header for various sections on this page)
* Topic names (will carry over to other pages)
* Product descriptions
* Description texts for Help Other Users and Suggestion Box
* Text for “See all news”
* Footer

Comment 4

5 years ago
Created attachment 650797 [details]
l10n product landing page

Comment 5

5 years ago
Created attachment 650799 [details]
l10n product landing page - with notes

Localizers would need to translate:
The rest of the topic names that are not covered by the homepage

That’s about it!

Comment 6

5 years ago
Created attachment 650801 [details]
l10n topic landing page

Comment 7

5 years ago
Created attachment 650802 [details]
l10n topic landing page - with notes

Localizers would need to translate:
* The rest of the topic names that are not covered by the homepage and the product landing page, for use in the sidebar
* Version and OS pickers
* As many articles as they can translate

Note the use of the “In English” heading to separate translated from non-translated items.

You’ll also see “In English” in use on attachment 650794 [details], where it’s used to mark that the items under Mozilla News and Hot Topics are not available in the locale language.
(Assignee)

Updated

5 years ago
Assignee: nobody → rrosario
Bram, for the topic landing page. Would we duplicate the topic names under "In English"?

How about showing something like "more articles in English" within each topic?

Comment 9

5 years ago
Kadir, we won’t duplicate the topic name in English. The worst case scenarion: let’s say that a locale does not have any article translated yet. What we would do then is still display the topic in the local language, but display the article title and the article itself in English.

Showing “more articles in English” is an option, but I like to offer user all the possible articles in the page, because the IA was designed to break articles apart in logical order so we can showcase them fully. If they have to click to get English articles, they might miss them entirely.
(Assignee)

Comment 10

5 years ago
I am confused about the Hot Topics section. Some or all of the articles marked as HOT will be translated and others may not be. Given that, the separator should probably be between two lists of articles instead of in the header.

Comment 11

5 years ago
The thinking that led to the design was this:
Because of the logistics that is involved in translating hot topic articles at an up-to-the-minute rate is a lot for many locales, I assumed that a locale will have none of the hot topic articles translated. That is, unless they want to be very timely at translating.

Is this the right assumption to make? If it’s not, I will design another solution where English and local articles could exist side by side in one section.

Rehan’s implementation of the Hot Topics section will have one column rather than two (because doing a two or three column layout is technically hacky). So, one hot topic per line.

Because every hot topic article is set on its own line, I believe that we will have enough space left for an “In English” text to be added either in the beginning or at the end of each line.

Comment 12

5 years ago
Bram,

thanks again for all the mock-ups, it looks great!

Just a few comments: 

- I think that when we display the articles in English we should have a somehow more visible "border". Like your are going now the "English" territory, so that users know right away

- I think that we should add a disclaimer, something along these lines: "These articles are also relevant to your search, but they haven't been translated yet. You can help us translate them here [link to contribute L10n]"

- About hot topics: I'm also a little confused as Ricky. Because for many locales the hot topics will be very often in English. So I think that we need here also a disclaimer or a way of preventing users to get the English content immediately without a warning. This could be again solved by a disclaimer, but I would rather solve it on the layout, because it's the very fist thing you see.

Thanks again for getting this done so quickly!

Rosana
(Assignee)

Updated

5 years ago
Target Milestone: 2012.16 → 2012.17
(Assignee)

Comment 13

5 years ago
Just landed on prod:

https://github.com/mozilla/kitsune/commit/483efcd20ceeb23e83cf7d749ddcfb1ca988ca95


We should take a look and iterate from here.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.