Last Comment Bug 781839 - Permanent OS X gcc build failure on Birch: "configure: error: installation or configuration problem: C compiler cannot create executables."
: Permanent OS X gcc build failure on Birch: "configure: error: installation or...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86 Mac OS X
: -- critical (vote)
: ---
Assigned To: :Ehsan Akhgari (busy, don't ask for review please)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-10 09:15 PDT by Ed Morley [:emorley]
Modified: 2012-08-10 10:01 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix merge problem (762 bytes, patch)
2012-08-10 09:30 PDT, Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
ehsan: review-
Details | Diff | Review

Description Ed Morley [:emorley] 2012-08-10 09:15:04 PDT
OS X 10.7 opt birch (ie gcc) builds started failing with:

https://tbpl.mozilla.org/php/getParsedLog.php?id=14294439&tree=Birch

{
configure: loading cache /builds/slave/bir-osx64/build/obj-firefox/i386/js/src/ctypes/libffi/config.cache
configure: error: `build_alias' has changed since the previous run:
configure:   former value:  `x86_64-apple-darwin11.2.0'
configure:   current value: `i386-apple-darwin11.2.0'
configure: error: in `/builds/slave/bir-osx64/build/obj-firefox/i386/js/src/ctypes/libffi':
configure: error: changes in the environment can compromise the build
configure: error: run `make distclean' and/or `rm /builds/slave/bir-osx64/build/obj-firefox/i386/js/src/ctypes/libffi/config.cache' and start over
}

We clobbered, but are still getting:

https://tbpl.mozilla.org/php/getParsedLog.php?id=14294932&tree=Birch

{
checking for gcc...  -arch i386
checking whether the C compiler ( -arch i386  ) works... no
configure: error: installation or configuration problem: C compiler cannot create executables.
*** Fix above errors and then restart with               "make -f client.mk build"
}

Changes in that push:
https://hg.mozilla.org/projects/birch/pushloghtml?changeset=e70a90ca2e57

Though don't know if this was a buildbot-configs change instead maybe?
Comment 1 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-08-10 09:21:50 PDT
This is a merge failure:

make -f /builds/slave/bir-osx64/build/client.mk realbuild
/builds/slave/bir-osx64/build/build/macosx/common: line 1: syntax error near unexpected token `<<<'
/builds/slave/bir-osx64/build/build/macosx/common: line 1: `<<<<<<< local'
Adding client.mk options from /builds/slave/bir-osx64/build/.mozconfig:

Probably from the bad hack in bug 778035 to fix seamonkey builds.
Comment 2 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-08-10 09:30:11 PDT
Created attachment 650912 [details] [diff] [review]
fix merge problem
Comment 3 :Ehsan Akhgari (busy, don't ask for review please) 2012-08-10 09:59:11 PDT
Comment on attachment 650912 [details] [diff] [review]
fix merge problem

Ah I did fix it in the previous merge, no idea why hg screwed this up again.  I'll fix it myself, thanks Rafael.
Comment 4 :Ehsan Akhgari (busy, don't ask for review please) 2012-08-10 10:01:28 PDT
https://hg.mozilla.org/projects/birch/rev/08b0fb32055f

Note You need to log in before you can comment on or make changes to this bug.