Split out analysis data that lives across collections from analysis-temporary in about:memory

RESOLVED DUPLICATE of bug 789398

Status

()

defect
RESOLVED DUPLICATE of bug 789398
7 years ago
7 years ago

People

(Reporter: mccr8, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MemShrink:P2][js:t])

Reporter

Description

7 years ago
See https://bugzilla.mozilla.org/show_bug.cgi?id=781767#c4

(In reply to Brian Hackett (:bhackett) from comment #4)
> A separate thing is that even when a GC clears analysis-temporary data,
> usage will not go to zero; the bucket describes an allocator that is cleared
> on each GC but is then immediately refilled with certain data that has to
> live across collections.  Bug 778724 also improves this, by splitting the
> allocator in two, and memory reporting could be improved as a followup to
> distinguish the two allocators (the current patch gloms them together).
In bug 775382 I saw the analysis-temporary numbers go negative, which indicates that it's possible for something to go wrong within the size computation.  In general, straight measurements of allocated memory (e.g. with malloc_usable_size) are preferable to computed sizes, because computed sizes are error-prone.  (https://wiki.mozilla.org/Memory_Reporting#Two_Ways_to_Measure has more details.)  So if the subtractions can be removed as part of this change, that would be great.
Whiteboard: [MemShrink] → [MemShrink:P2]
Whiteboard: [MemShrink:P2] → [MemShrink:P2][js:t]
Reporter

Comment 2

7 years ago
Nick, is this a dupe of bug 789398?
Yes!  Thanks.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 789398
You need to log in before you can comment on or make changes to this bug.