l10n_slaves cannot be overridden

RESOLVED FIXED

Status

Release Engineering
General
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: jhopkins, Assigned: jhopkins)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
While trying to set l10n_slaves in mozilla-inbound, I noticed that our automation does not allow that since it doesn't check whether l10n_slaves is already set before setting that value:

 https://hg.mozilla.org/build/buildbot-configs/file/8fea6fabd400/mozilla/builder_master.cfg#l65
(Assignee)

Comment 1

6 years ago
Created attachment 650981 [details] [diff] [review]
proposed buildbot-configs patch

Tested that this patch passes setup-master.py tests for all masters, that dump_masters.sh output is the same before and after the patch, and a change to l10n_slaves in the mozilla-inbound project branch takes effect with this patch applied.
Attachment #650981 - Flags: review?(rail)
Comment on attachment 650981 [details] [diff] [review]
proposed buildbot-configs patch

lgtm
Attachment #650981 - Flags: review?(rail) → review+
(Assignee)

Comment 3

6 years ago
Comment on attachment 650981 [details] [diff] [review]
proposed buildbot-configs patch

Landed in https://hg.mozilla.org/build/buildbot-configs/rev/82683039a46f
Attachment #650981 - Flags: checked-in+
In production since yesterday.
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.