Last Comment Bug 781945 - Improve GC telemetry
: Improve GC telemetry
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla17
Assigned To: Bill McCloskey (:billm)
: general
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-10 15:13 PDT by Bill McCloskey (:billm)
Modified: 2012-08-14 06:02 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (8.08 KB, patch)
2012-08-10 15:13 PDT, Bill McCloskey (:billm)
continuation: review+
Details | Diff | Splinter Review

Description Bill McCloskey (:billm) 2012-08-10 15:13:40 PDT
Created attachment 651010 [details] [diff] [review]
patch

This fixes the problem where GC_MS records the total time between the start and the end of the GC. I considered using a different histogram for this, but since the old one is totally useless, I think we should just replace it.

It also adds a max pause field, which is a little more useful than the GC_SLICE_MS histogram, which records the time of every slice, and so tends to be somewhat optimistic.

I also had it record the time for root marking and gray marking. I don't have a good idea of how long these phases are taking in the wild, so it would be good to get some data on this.
Comment 1 Andrew McCreight [:mccr8] 2012-08-10 15:29:32 PDT
Comment on attachment 651010 [details] [diff] [review]
patch

Review of attachment 651010 [details] [diff] [review]:
-----------------------------------------------------------------

Nice!

::: toolkit/components/telemetry/TelemetryHistograms.h
@@ +56,4 @@
>  HISTOGRAM(GC_MARK_MS, 1, 10000, 50, EXPONENTIAL, "Time spent running JS GC mark phase (ms)")
>  HISTOGRAM(GC_SWEEP_MS, 1, 10000, 50, EXPONENTIAL, "Time spent running JS GC sweep phase (ms)")
> +HISTOGRAM(GC_MARK_ROOTS_MS, 1, 200, 50, LINEAR, "Time spent running JS GC mark phase (ms)")
> +HISTOGRAM(GC_MARK_GRAY_MS, 1, 200, 50, LINEAR, "Time spent running JS GC mark phase (ms)")

nit: The descriptions of MARK_GRAY needs to be fixed.
Comment 3 Ed Morley [:emorley] 2012-08-14 06:02:17 PDT
https://hg.mozilla.org/mozilla-central/rev/65bc2e5b574f

Note You need to log in before you can comment on or make changes to this bug.