Last Comment Bug 781985 - IonMonkey: visitCallDOMNative() must dropArguments()
: IonMonkey: visitCallDOMNative() must dropArguments()
Status: RESOLVED FIXED
[ion:p1]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Sean Stangl [:sstangl]
:
:
Mentors:
http://lights.elliegoulding.com
Depends on:
Blocks: LandIon
  Show dependency treegraph
 
Reported: 2012-08-10 17:34 PDT by Sean Stangl [:sstangl]
Modified: 2012-08-10 18:05 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Backtrace. (2.63 KB, text/plain)
2012-08-10 17:34 PDT, Sean Stangl [:sstangl]
no flags Details
patch (726 bytes, patch)
2012-08-10 17:58 PDT, Sean Stangl [:sstangl]
efaustbmo: review+
Details | Diff | Splinter Review

Description Sean Stangl [:sstangl] 2012-08-10 17:34:10 PDT
Created attachment 651059 [details]
Backtrace.

Asserts in an x86_64 Ion debug browser by visiting http://lights.elliegoulding.com, waiting for it to load, and clicking "Play".

The problem is most likely that visitCallDOMNative() is missing a call to dropArguments().

Backtrace attached.
Comment 1 Sean Stangl [:sstangl] 2012-08-10 17:58:16 PDT
Created attachment 651065 [details] [diff] [review]
patch

Fixes crash. Site runs happily if jankily.
Comment 2 Sean Stangl [:sstangl] 2012-08-10 18:05:52 PDT
http://hg.mozilla.org/projects/ionmonkey/rev/32b7b76d111c

Note You need to log in before you can comment on or make changes to this bug.