Closed Bug 781997 Opened 7 years ago Closed 7 years ago

ogg audio files playback is garbled

Categories

(Core :: Audio/Video, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 775319
blocking-basecamp +

People

(Reporter: onecyrenus, Unassigned)

Details

otoro device
gecko: commit_id: feb0fa83e3e218c12b4efe2e34fcf2494aa61718
gaia: commit_id: 9cc19a277b88d80040f1a76f2168a9aeae9c7d2f

Play any ogg audio file and the playback is garbled / terrible.  

logcat output to follow, but there don't seem to be many clues there.
W/AudioFlinger(  113): Thread AudioOut_1 cannot connect to the power manager service
E/AudioHardwareMSM76XXA(  113): Parsing error in AudioFilter.csv.
E/GeckoConsole(  107): GC(T+2000.0) Total Time: 197.1ms, Compartments Collected: 109, Total Compartments: 109, MMU (20ms): 0%, MMU (50ms): 0%, Max Pause: 65.9ms, Allocated: 11MB, +Chunks: 0, -Chunks: 0
E/GeckoConsole(  107):     Slice: 0, Pause: 33.4 (When: 0.0ms, Reason: CC_WAITING): Purge: 0.2ms, Mark: 30.6ms, Mark Discard Code: 1.9ms, Mark Roots: 6.3ms
E/GeckoConsole(  107):     Slice: 3, Pause: 65.9 (When: 414.1ms, Reason: INTER_SLICE_GC): Mark: 16.2ms, Mark Weak: 0.2ms, Mark Gray: 15.8ms, Mark Gray and Weak: 0.2ms, Finalize Start Callback: 0.6ms, Sweep: 47.9ms, Sweep Atoms: 19.1ms, Sweep Compartments: 18.3ms, Sweep Tables: 8.9ms, Sweep Object: 4.4ms, Sweep String: 0.3ms, Sweep Script: 0.6ms, Sweep Shape: 0.2ms, Sweep Discard Code: 4.1ms, Discard Analysis: 4.8ms, Discard TI: 1.1ms, Free TI Arena: 0.1ms, Sweep Types: 2.0ms, Clear Script Analysis: 0.8ms, Finalize End Callback: 3.4ms
E/GeckoConsole(  107):     Slice: 4, Pause: 18.2 (When: 580.8ms, Reason: INTER_SLICE_GC): Sweep: 5.3ms, Sweep Shape: 5.2ms, Deallocate: 0.1ms
E/GeckoConsole(  107):     Totals: Purge: 0.2ms, Mark: 125.3ms, Mark Discard Code: 1.9ms, Mark Roo
E/GeckoConsole(  107): CC(T+2000.0) duration: 46ms, suspected: 239, visited: 1288 RCed and 1226 GCed, collected: 31 RCed and 19 GCed (50 waiting for GC)
E/GeckoConsole(  107): ForgetSkippable 3 times before CC, min: 0 ms, max: 14 ms, avg: 5 ms, total: 16 ms, removed: 347
blocking-basecamp: --- → ?
When did you last test? A serious audio bug was introduced in bug 775319 which was backed out about 24 hours ago. Does your test build have this backout?
I don't believe so, I believe this is a dupe.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 775319
Just double checked.  775319 backout has not made it to mozilla-central as of yet.
blocking-basecamp: ? → +
You need to log in before you can comment on or make changes to this bug.