crash in ReadInternetOption @ MEMMAP_FILE::GetHeaderData

RESOLVED WORKSFORME

Status

()

Core
Networking
--
critical
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: Scoobidiver (away), Assigned: emk)

Tracking

({crash, regression})

16 Branch
x86
Windows XP
crash, regression
Points:
---

Firefox Tracking Flags

(firefox16-)

Details

(crash signature)

(Reporter)

Description

5 years ago
It's a low volume crash but high on 16.0a2: #40 top browser crasher.
It seems a regression from bug 771115.

Signature 	MEMMAP_FILE::GetHeaderData(unsigned long, unsigned long*) More Reports Search
UUID	48912415-4236-492f-a4a1-7b7462120729
Date Processed	2012-07-29 23:16:15
Uptime	42
Install Age	42 seconds since version was first installed.
Install Time	2012-07-29 23:15:00
Product	Firefox
Version	17.0a1
Build ID	20120728030524
Release Channel	nightly
OS	Windows NT
OS Version	5.1.2600 Service Pack 2
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 42 stepping 7
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x6d001cc
App Notes 	
AdapterVendorID: 0x8086, AdapterDeviceID: 0x0102, AdapterSubsysID: 7b971019, AdapterDriverVersion: 6.14.10.5361
D3D10 Layers? D3D10 Layers- D3D9 Layers? D3D9 Layers+ 
EMCheckCompatibility	True
Adapter Vendor ID	0x8086
Adapter Device ID	0x0102
Total Virtual Memory	2147352576
Available Virtual Memory	1746305024
System Memory Use Percentage	21
Available Page File	4784902144
Available Physical Memory	2676355072

Frame 	Module 	Signature 	Source
0 	wininet.dll 	MEMMAP_FILE::GetHeaderData 	
1 	wininet.dll 	URL_CONTAINER::GetHeaderData 	
2 	wininet.dll 	GetCurrentSettingsVersion 	
3 	wininet.dll 	InternetSettingsChanged 	
4 	wininet.dll 	FixProxySettings 	
5 	wininet.dll 	TransformMD5 	
6 	xul.dll 	ReadInternetOption 	toolkit/system/windowsproxy/nsWindowsSystemProxySettings.cpp:84
7 	xul.dll 	nsWindowsSystemProxySettings::GetPACURI 	toolkit/system/windowsproxy/nsWindowsSystemProxySettings.cpp:205
8 	xul.dll 	nsProtocolProxyService::Resolve_Internal 	netwerk/base/src/nsProtocolProxyService.cpp:1251
9 	xul.dll 	nsProtocolProxyService::Resolve 	netwerk/base/src/nsProtocolProxyService.cpp:829
10 	xul.dll 	nsIOService::LookupProxyInfo 	netwerk/base/src/nsIOService.cpp:596
11 	xul.dll 	nsIOService::NewChannelFromURIWithProxyFlags 	netwerk/base/src/nsIOService.cpp:632
12 	xul.dll 	nsIOService::NewChannelFromURI 	netwerk/base/src/nsIOService.cpp:576
13 	xul.dll 	NS_NewChannel 	obj-firefox/dist/include/nsNetUtil.h:192
14 	xul.dll 	nsXMLHttpRequest::Open 	content/base/src/nsXMLHttpRequest.cpp:1895
15 	xul.dll 	nsXMLHttpRequest::Open 	content/base/src/nsXMLHttpRequest.h:263
16 	xul.dll 	mozilla::dom::XMLHttpRequestBinding::open 	obj-firefox/dom/bindings/XMLHttpRequestBinding.cpp:241
17 	mozjs.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:345
18 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:2405
...

More reports at:
https://crash-stats.mozilla.com/report/list?signature=MEMMAP_FILE%3A%3AGetHeaderData%28unsigned+long%2C+unsigned+long*%29
(Reporter)

Comment 1

5 years ago
It's #14 top browser crasher in 16.0b1.
tracking-firefox16: --- → ?
Keywords: topcrash

Comment 2

5 years ago
Masatoshi/Jim - do you agree that this is a regression from bug 771115?
Assignee: nobody → VYV03354
tracking-firefox16: ? → +
(Assignee)

Comment 3

5 years ago
Maybe, but I have no idea how to fix this (looks like operating system's bug).
And a simple backout will cause another serious issue (bug 774242).

Comment 4

5 years ago
No longer a top crasher on recent betas (hovering around #50) - untracking.
tracking-firefox16: + → -
(Reporter)

Updated

5 years ago
Keywords: topcrash

Updated

2 years ago
Crash Signature: [@ MEMMAP_FILE::GetHeaderData(unsigned long, unsigned long*)] → [@ MEMMAP_FILE::GetHeaderData(unsigned long, unsigned long*)] [@ MEMMAP_FILE::GetHeaderData]
gone from crash stats
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.