Last Comment Bug 782077 - IonMonkey: Remove MIRType_Any
: IonMonkey: Remove MIRType_Any
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Tom Schuster [:evilpie]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-11 14:45 PDT by Tom Schuster [:evilpie]
Modified: 2012-08-13 06:04 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
remove MIRType_Any (3.04 KB, patch)
2012-08-11 14:45 PDT, Tom Schuster [:evilpie]
jdemooij: review+
Details | Diff | Review

Description Tom Schuster [:evilpie] 2012-08-11 14:45:35 PDT
Created attachment 651154 [details] [diff] [review]
remove MIRType_Any

We don't use it.
Comment 1 Jan de Mooij [:jandem] 2012-08-13 01:39:02 PDT
Comment on attachment 651154 [details] [diff] [review]
remove MIRType_Any

Review of attachment 651154 [details] [diff] [review]:
-----------------------------------------------------------------

Good catch. Can you also remove MIRType_UpvarSlots while you are here? It's unused since bug 730497 removed flat closures.
Comment 2 Tom Schuster [:evilpie] 2012-08-13 06:04:47 PDT
Thanks & done.
http://hg.mozilla.org/projects/ionmonkey/rev/6c3ea389b47e

Note You need to log in before you can comment on or make changes to this bug.