java.lang.NullPointerException: at android.os.Parcel.readException(Parcel.java) on Galaxy Tab 7.7" (GT-P6800) with Honeycomb

RESOLVED FIXED in Firefox 16

Status

()

Firefox for Android
Keyboards and IME
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Scoobidiver (away), Assigned: cpeterson)

Tracking

({crash})

15 Branch
Firefox 18
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(firefox15 wontfix, firefox16 fixed, firefox17 fixed, firefox18 fixed, fennec-)

Details

(Whiteboard: [native-crash][startupcrash], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
There are 65 crashes in 15.0 Beta, including bp-c2304ebc-8734-4ed8-8c28-6f76f2120811.

java.lang.NullPointerException
	at android.os.Parcel.readException(Parcel.java:1327)
	at android.os.Parcel.readException(Parcel.java:1275)
	at com.android.internal.view.IInputMethodManager$Stub$Proxy.hideSoftInput(IInputMethodManager.java:606)
	at android.view.inputmethod.InputMethodManager.hideSoftInputFromWindow(InputMethodManager.java:857)
	at android.view.inputmethod.InputMethodManager.hideSoftInputFromWindow(InputMethodManager.java:829)
	at org.mozilla.gecko.AwesomeBar$6.onFocusChange(AwesomeBar.java:241)
	at android.view.View.onFocusChanged(View.java:3419)
	at android.widget.TextView.onFocusChanged(TextView.java:7614)
	at android.widget.EditText.onFocusChanged(EditText.java:136)
	at android.view.View.unFocus(View.java:3347)
	at android.view.ViewGroup.unFocus(ViewGroup.java:630)
	at android.view.ViewGroup.requestChildFocus(ViewGroup.java:512)
	at android.view.ViewGroup.requestChildFocus(ViewGroup.java:518)
	at android.view.ViewGroup.requestChildFocus(ViewGroup.java:518)
	at android.view.ViewGroup.requestChildFocus(ViewGroup.java:518)
	at android.view.ViewGroup.requestChildFocus(ViewGroup.java:518)
	at android.view.View.handleFocusGainInternal(View.java:3239)
	at android.view.View.requestFocus(View.java:4460)
	at android.view.View.requestFocus(View.java:4410)
	at android.view.View.requestFocus(View.java:4388)
	at android.widget.TabHost.onTouchModeChanged(TabHost.java:204)
	at android.view.ViewTreeObserver.dispatchOnTouchModeChanged(ViewTreeObserver.java:606)
	at android.view.ViewRoot.ensureTouchModeLocally(ViewRoot.java:2331)
	at android.view.ViewRoot.ensureTouchMode(ViewRoot.java:2315)
	at android.view.View.requestFocusFromTouch(View.java:4485)
	at org.mozilla.gecko.AwesomeBar.onKeyDown(AwesomeBar.java:471)
	at android.view.KeyEvent.dispatch(KeyEvent.java:2540)
	at android.app.Activity.dispatchKeyEvent(Activity.java:2280)
	at com.android.internal.policy.impl.PhoneWindow$DecorView.dispatchKeyEvent(PhoneWindow.java:1819)
	at android.view.ViewRoot.deliverKeyEventPostIme(ViewRoot.java:2963)
	at android.view.ViewRoot.handleMessage(ViewRoot.java:2234)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:132)
	at android.app.ActivityThread.main(ActivityThread.java:4123)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:491)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:849)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:607)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+at+android.os.Parcel.readException%28Parcel.java%29
(Assignee)

Comment 1

5 years ago
Curiously, these hideSoftInputFromWindow() crashes are all Galaxy Tab users running Android 3.2 (Honeycomb). 

The NPE is [re]thrown by Parcel.readException(), which means the original NPE was thrown from InputMethodManagerService's hideSoftInput(). I wonder if there was a bug in Honeycomb's InputMethodManagerService that was fixed in ICS? Our client should not be able to trigger NPEs in the service!
(Reporter)

Updated

5 years ago
Summary: java.lang.NullPointerException: at android.os.Parcel.readException(Parcel.java) on Galaxy Tab 7.7" (GT-P6800) → java.lang.NullPointerException: at android.os.Parcel.readException(Parcel.java) on Galaxy Tab 7.7" (GT-P6800) with Honeycomb
(Assignee)

Comment 2

5 years ago
Created attachment 656966 [details] [diff] [review]
catch-NPE.patch

Catch unexpected NullPointerException from InputMethodManagerService.
Assignee: nobody → cpeterson
Status: NEW → ASSIGNED
Attachment #656966 - Flags: review?(snorp)
(Assignee)

Comment 3

5 years ago
(In reply to Chris Peterson (:cpeterson) from comment #2)
> Created attachment 656966 [details] [diff] [review]
> catch-NPE.patch
> 
> Catch unexpected NullPointerException from InputMethodManagerService.

snorp, have you had a chance to review my fix for this InputMethodManagerService NullPointerException we discussed in last week's Bug Deep Dive meeting?
Comment on attachment 656966 [details] [diff] [review]
catch-NPE.patch

Review of attachment 656966 [details] [diff] [review]:
-----------------------------------------------------------------

Gross, but looks good.
Attachment #656966 - Flags: review?(snorp) → review+
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/41cf3c361d9d
status-firefox18: --- → fixed
Target Milestone: --- → Firefox 18
https://hg.mozilla.org/mozilla-central/rev/41cf3c361d9d
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

5 years ago
Comment on attachment 656966 [details] [diff] [review]
catch-NPE.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): N/A
User impact if declined: Intermittent crashes for some Honeycomb tablet users. I suspect this is a bug in Honeycomb that was fixed in ICS+.
Testing completed (on m-c, etc.): Tested locally, BUT this is an intermittent bug I have not repro'd myself.
Risk to taking this patch (and alternatives if risky): Low risk. The code change simply catches a NullPointerException from Google code instead of crashing.
String or UUID changes made by this patch: N/A
Attachment #656966 - Flags: approval-mozilla-beta?
Attachment #656966 - Flags: approval-mozilla-aurora?
Comment on attachment 656966 [details] [diff] [review]
catch-NPE.patch

mobile-only, low risk, still early in beta - we can take this to branches.
Attachment #656966 - Flags: approval-mozilla-beta?
Attachment #656966 - Flags: approval-mozilla-beta+
Attachment #656966 - Flags: approval-mozilla-aurora?
Attachment #656966 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 9

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/61502f07b33c
status-firefox17: --- → fixed
(Assignee)

Comment 10

5 years ago
https://hg.mozilla.org/releases/mozilla-beta/rev/e34089cb1120
status-firefox15: --- → wontfix
status-firefox16: --- → fixed
This is still crashing at about the same rate as mentioned in comment 0.
Status: RESOLVED → REOPENED
tracking-fennec: --- → ?
Resolution: FIXED → ---
tracking-fennec: ? → 18+
Let's open a new bug for this. The patch was landed and pushed all the way to beta.
Status: REOPENED → RESOLVED
tracking-fennec: 18+ → -
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.