Port relevant changes from |Bug 215450 - uploading files that are larger the 2GB fails|

RESOLVED FIXED

Status

MailNews Core
Networking
--
blocker
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Ian Neal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 215450])

(Reporter)

Description

5 years ago
Now that Bug 215450 has landed on mozilla-central we are broken.
e.g.
/builds/slave/comm-cen-trunk-lnx/build/mailnews/base/src/nsMessenger.cpp: In member function ‘virtual nsresult nsSaveMsgListener::OnDataAvailable(nsIRequest*, nsISupports*, nsIInputStream*, PRUint32, PRUint32)’:
/builds/slave/comm-cen-trunk-lnx/build/mailnews/base/src/nsMessenger.cpp:1908:40: error: no matching function for call to ‘nsIInputStream::Available(PRUint32*)’
../../../mozilla/dist/include/nsIInputStream.h:66:60: note: candidate is: virtual nsresult nsIInputStream::Available(PRUint64*)
NEXT ERROR make[6]: *** [nsMessenger.o] Error 1
(Reporter)

Updated

5 years ago
Component: Backend → Networking
OS: Linux → All
Hardware: x86_64 → All
(Reporter)

Comment 1

5 years ago
There is a patch already waiting for review over in bug 215450
(Reporter)

Updated

5 years ago
Severity: normal → blocker
Duplicate of this bug: 782255
This has hopefully been fixed by bug 215450. I'll check on the trees in the morning and re-open if they go green.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 215450]
You need to log in before you can comment on or make changes to this bug.