Page cache invalidated after moving dynamically created textarea before existing textarea

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: Cacycle, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.46 KB, text/html
Details
(Reporter)

Description

6 years ago
Created attachment 651207 [details]
Testcase

Page cache invalidated after moving dynamically created textarea before existing textarea

The page cache saves the page content including textarea content and JavaScript state when navigating away from a page (see https://developer.mozilla.org/en-US/docs/Using_Firefox_1.5_caching). This page caching breaks (i.e. the page cache is invalidated for this page) when moving a dynamically created textarea before an already existing textarea.

Please open the the attached testcase and follow the instructions to replicate this bug:

1. Change content of original textarea
2. Click the Google link
3. Come back to the testcase page by using the left arrow button
4. The changed content of the original textarea is preserved, i.e. the page cache has not been invalidated
5. Click the button to move the dynamically created textarea before the original textarea
6. Click the Google link and come back as before
7. The changed content of the original textarea is not preserved, i.e. the page cache has been invalidated

This is a major problem for rich text editors such as the Wikipedia editor wikEd because edits get lost when navigating away from the editing page.

This bug has been observed in Firefox 14.0.1 under Windows XP and is probably present since at least March 24, 2012 (see https://bugzilla.wikimedia.org/show_bug.cgi?id=22680). The testcase works as supposed under Chrome 21.0.1180.75 m.
(Reporter)

Updated

6 years ago
Attachment #651207 - Attachment mime type: text/plain → text/html

Comment 1

6 years ago
This works fine for me on Firefox 14.0.1 on Ubuntu. After clicking the button that moves the textarea, the bfcache still works fine.

Comment 2

5 years ago
Firefox 15.0.1, worksforme.
Marking as worksforme, Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/17.0 Firefox/17.0.

If the reporter has any other information, please post here and reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

5 years ago
Cache invalidation was actually caused by the addon Ant Video Downloader 2.4.7.4. I have reported this bug to them, please see http://support.ant.com/requests/6520
You need to log in before you can comment on or make changes to this bug.