Last Comment Bug 782185 - don't use EXTEND_NONE in image layers
: don't use EXTEND_NONE in image layers
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics: Layers (show other bugs)
: 13 Branch
: x86_64 Linux
: -- normal (vote)
: mozilla17
Assigned To: Karl Tomlinson (ni?:karlt)
:
Mentors:
Depends on:
Blocks: 567370
  Show dependency treegraph
 
Reported: 2012-08-12 22:43 PDT by Karl Tomlinson (ni?:karlt)
Modified: 2012-08-17 05:27 PDT (History)
5 users (show)
karlt: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
provide a gfxXlibSurface method to indicate when cairo's extend_pad will be slow (2.77 KB, patch)
2012-08-12 22:49 PDT, Karl Tomlinson (ni?:karlt)
joe: review+
Details | Diff | Review
use extend_pad when compositing image layers even for Quartz and X11 (3.66 KB, patch)
2012-08-12 22:52 PDT, Karl Tomlinson (ni?:karlt)
roc: review+
Details | Diff | Review

Description Karl Tomlinson (ni?:karlt) 2012-08-12 22:43:37 PDT
When there is a transform, EXTEND_NONE is not what we want, is incorrectly implemented by NVIDIA drivers to extend CONTENT_COLOR surfaces with black, and is slower than EXTEND_PAD with other drivers.
Comment 1 Karl Tomlinson (ni?:karlt) 2012-08-12 22:49:26 PDT
Created attachment 651268 [details] [diff] [review]
provide a gfxXlibSurface method to indicate when cairo's extend_pad will be slow
Comment 2 Karl Tomlinson (ni?:karlt) 2012-08-12 22:50:59 PDT
The only supported free distribution that I know still has one of these old
servers is OpenSUSE 11.2.  It has xorg server 1.6.5 and I understand the
Evergreen community is endeavouring to support this version.  (The oldest
currently supported Debian release is 6.0 squeeze which has xorg-server 1.7.7.
Ubuntu 10.04 LTS has 1.7.6.)

The latest SLES, 11-SP2 also still has only xorg-server 1.6.5.  Their
customers should expect a functional RepeatPad, but unfortunately cairo will
effect the workaround and take the readback path.
Comment 3 Karl Tomlinson (ni?:karlt) 2012-08-12 22:52:51 PDT
Created attachment 651270 [details] [diff] [review]
use extend_pad when compositing image layers even for Quartz and X11

Bug 562746 comment 65 removed use of EXTEND_NONE in gfxDrawable with Quartz
because of changes in the cairo implementation, so I expect the same reasoning
to apply here.

Note You need to log in before you can comment on or make changes to this bug.