Last Comment Bug 782217 - Http request sent twice with evince or jsPDFviewer but not AcrobatReader
: Http request sent twice with evince or jsPDFviewer but not AcrobatReader
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: PDF Viewer (show other bugs)
: 14 Branch
: x86 Windows XP
: -- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 784718
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 02:29 PDT by Laurent Fournier
Modified: 2012-08-27 14:07 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Laurent Fournier 2012-08-13 02:29:19 PDT
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

My application is an html page embedding a PDF rendering in some object tag.



Actual results:

If FF client has the javascript PDFViewer addon on Windows or mozpluger on Linux to use 'evince', then the GET request is sent twice.
If the windows client is configured with AcrobatReader plugin, it works well (the GET request is sent once)


Expected results:

The client shoud send the GET request once.
This is NOT related to 236858 bug. I played with encoding both in content-type and meta tag, and nothing change. Also, the same code works well with Acrobat.
I tested also on Nightly 17.0a1, same bug.

To reproduce the bug:
See http://pi.pelinquin.fr/u?bug with firebug and (evince or PDFviewer)
(wait 20 secondes de generate PDF, because it is a RaspberryPi server!)

Note that if Firefox is planing to embedd its own PDFviewer, this bug should be fixed.
Comment 1 Yury Delendik (:yury) 2012-08-14 14:33:55 PDT
> If FF client has the javascript PDFViewer addon on Windows or mozpluger on Linux
> to use 'evince', then the GET request is sent twice.

Laurent,

The PDF Viewer is an component of the Firefox; and mozpluger and evince third-party utils. Does the issue concern only PDF Viewer, mozpluger with evince, or both of them? If both of them, please split this bug into two separate bugs since it will be hard to follow the resolution of these two unrelated issues in one place.

Thanks
Comment 2 Yury Delendik (:yury) 2012-08-15 08:21:54 PDT
First half of the bug (about pdf viewer) as a duplicate of https://github.com/mozilla/pdf.js/issues/1907
Comment 3 Laurent Fournier 2012-08-17 02:02:04 PDT
@Yury,

The same wrong (two GET requests) behavior is observed in the cases:
FF or Nightly 17.0a1 on (Windows or Linux) with js PDF viewer 0.3452 extension
FF or Nightly 17.0a1 on Linux with mozplugger 1.14.3 with (evince or okular) to render PDF
But things are working well both on Windows or Linux with Acroread plugin

So I suspect the same kind of bug both in jsPDFviewer and mozplugger.
Thanks for the Github issue link. I am not sure mozplugger problem report is very active!

Anyway, if at short term, it is planned to embed a PDF viewer in FF (without plugin), then it would be nice to render the PDF using only one request.
Meanwhile, I will ask users to use the (heavy, not Open-source) Acroread!
Comment 4 Virgil Dicu [:virgil] [QA] 2012-08-21 09:29:49 PDT
(In reply to Yury (:yury) from comment #2)
> First half of the bug (about pdf viewer) as a duplicate of
> https://github.com/mozilla/pdf.js/issues/1907

A bit offtopic, but still: what's the procedure for PDF viewer bugs filed in bugzilla? Seems these are actively worked upon in github, but a lot of user reports are filed here. We can't really duplicate them to github. So would just moving them to the bugzilla pdf viewer component suffice?
Comment 5 Yury Delendik (:yury) 2012-08-21 10:16:37 PDT
Virgil, does that mean that PDF Viewer covers fixing of the "FF or Nightly 17.0a1 on Linux with mozplugger 1.14.3 with (evince or okular) to render PDF" issue?
Comment 6 Virgil Dicu [:virgil] [QA] 2012-08-21 10:18:54 PDT
Nope, that meaqns I'm asking what to do with related firefox pdf viewer bugs (excluding this case) logged in bugzilla. Search for related items both on github and bugzilla?
Comment 7 Yury Delendik (:yury) 2012-08-21 10:31:53 PDT
The pdf.js team is handling both bugzilla and github issues. Mostly bugzilla has issues related to the PDF Viewer integration (the github will not have those issues). If duplicates are found, the issues will be cross-referenced.

More generic discussion about github vs bugzilla can be found at https://groups.google.com/forum/?fromgroups=#!msg/mozilla.dev.planning/CTJAcljUgzQ/n45bkm9TCxcJ
Comment 8 Yury Delendik (:yury) 2012-08-27 14:07:31 PDT
Resolved by bug 784718:

> #1943 Implements loading PDF data by extension/chrome

Note You need to log in before you can comment on or make changes to this bug.