Last Comment Bug 782317 - [AccessFu] appinfo.OS == 'Android' does not always mean Android
: [AccessFu] appinfo.OS == 'Android' does not always mean Android
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla17
Assigned To: Eitan Isaacson [:eeejay]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 10:03 PDT by Eitan Isaacson [:eeejay]
Modified: 2012-08-16 06:19 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Change platform conditionals for Android Firefox to "mobile/android". (2.66 KB, patch)
2012-08-13 10:04 PDT, Eitan Isaacson [:eeejay]
dbolter: review+
Details | Diff | Review

Description Eitan Isaacson [:eeejay] 2012-08-13 10:03:47 PDT
Apparently, B2G will also report its OS to be Android, so we should use the build app name instead, 'mobile/android'.
Comment 1 Eitan Isaacson [:eeejay] 2012-08-13 10:04:44 PDT
Created attachment 651439 [details] [diff] [review]
Change platform conditionals for Android Firefox to "mobile/android".
Comment 2 David Bolter [:davidb] 2012-08-13 10:10:15 PDT
Comment on attachment 651439 [details] [diff] [review]
Change platform conditionals for Android Firefox to "mobile/android".

Review of attachment 651439 [details] [diff] [review]:
-----------------------------------------------------------------

r=me. Do you know specifically why b2g chooses to report Android?
Comment 3 Eitan Isaacson [:eeejay] 2012-08-13 10:11:18 PDT
(In reply to David Bolter [:davidb] from comment #2)
> Comment on attachment 651439 [details] [diff] [review]
> Change platform conditionals for Android Firefox to "mobile/android".
> 
> Review of attachment 651439 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> r=me. Do you know specifically why b2g chooses to report Android?

No, I bet it will eventually be "Gonk", but I think the changes here make sense anyway.
Comment 4 David Bolter [:davidb] 2012-08-13 10:12:21 PDT
What about this conditional - is it okay to keep using 'Android' here?

if (Utils.OS != 'Android' && !aEvent.shiftKey)
Comment 5 Eitan Isaacson [:eeejay] 2012-08-13 10:14:12 PDT
(In reply to David Bolter [:davidb] from comment #4)
> What about this conditional - is it okay to keep using 'Android' here?
> 
> if (Utils.OS != 'Android' && !aEvent.shiftKey)

I think so, since that distinguishes device from desktop testing. BTW, I am doing a gesture rework, so that will end up somewhere else soon anyway.
Comment 7 Ed Morley [:emorley] 2012-08-16 06:19:16 PDT
https://hg.mozilla.org/mozilla-central/rev/e0876ea69295

Note You need to log in before you can comment on or make changes to this bug.