Last Comment Bug 782332 - Retained tiles should not be used with fixed-position layers
: Retained tiles should not be used with fixed-position layers
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics: Layers (show other bugs)
: unspecified
: ARM Android
: -- normal (vote)
: mozilla17
Assigned To: Chris Lord [:cwiiis]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 10:25 PDT by Chris Lord [:cwiiis]
Modified: 2012-08-20 09:50 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Don't retain tiles on fixed position layers (2.20 KB, patch)
2012-08-13 13:22 PDT, Chris Lord [:cwiiis]
bgirard: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Review

Description Chris Lord [:cwiiis] 2012-08-13 10:25:48 PDT
Fixed position layers don't move, so it doesn't make sense to try to retain tiles. Currently, it just ends up causing weird-looking rendering glitches. We should just not use them for fixed position layers.

Eventually retained tiles will be superseded by on-demand tile rendering work, but this is an easy thing to do that will improve the experience on sites with top/bottom bars, etc.
Comment 1 Chris Lord [:cwiiis] 2012-08-13 13:22:20 PDT
Created attachment 651516 [details] [diff] [review]
Don't retain tiles on fixed position layers
Comment 2 Benoit Girard (:BenWa) 2012-08-13 14:26:06 PDT
Comment on attachment 651516 [details] [diff] [review]
Don't retain tiles on fixed position layers

r+, nice detailed comment.
Comment 3 Chris Lord [:cwiiis] 2012-08-13 20:02:58 PDT
Pushed to inbound:

https://hg.mozilla.org/integration/mozilla-inbound/rev/84f253d1174c
Comment 4 Chris Lord [:cwiiis] 2012-08-13 20:15:20 PDT
Comment on attachment 651516 [details] [diff] [review]
Don't retain tiles on fixed position layers

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Rendering artifacts when panning/zooming on pages with fixed-position elements
User impact if declined: See above
Testing completed (on m-c, etc.): Tested locally
Risk to taking this patch (and alternatives if risky): Low - just disables a feature in a simple and reliable way.
String or UUID changes made by this patch: None
Comment 5 Ed Morley [:emorley] 2012-08-14 05:59:39 PDT
https://hg.mozilla.org/mozilla-central/rev/84f253d1174c
Comment 6 Chris Lord [:cwiiis] 2012-08-20 06:57:07 PDT
Pushed to aurora: http://hg.mozilla.org/releases/mozilla-aurora/rev/bb764cfc347a

Note You need to log in before you can comment on or make changes to this bug.