The default bug view has changed. See this FAQ.

crash in nsIFrame::GetUsedBorder

RESOLVED DUPLICATE of bug 781265

Status

()

Core
DOM
--
critical
RESOLVED DUPLICATE of bug 781265
5 years ago
5 years ago

People

(Reporter: marcia, Assigned: johns)

Tracking

({crash, regression, reproducible})

17 Branch
crash, regression, reproducible
Points:
---

Firefox Tracking Flags

(firefox17+ fixed)

Details

(crash signature, URL)

(Reporter)

Description

5 years ago
This bug was filed from the Socorro interface and is 
report bp-b2d9aabc-58ff-4366-a434-834f42120813 .
============================================================= 

Seen while looking at crash stats. nsRootPresContext::GetPluginGeometryUpdates is further down in the stack so wondering if it is the same or related to Bug 781272.

https://crash-stats.mozilla.com/report/list?signature=nsIFrame::GetUsedBorder

STR:
1. Load http://www.zataz.com/news/22329/photobucket_-photo_-hack_-fusking.html
2. Resize the page.


Frame 	Module 	Signature 	Source
0 	XUL 	nsIFrame::GetUsedBorder 	nsIFrame.h:1149
1 	XUL 	nsIFrame::GetContentRect 	nsIFrame.h:965
2 	XUL 	PluginBoundsEnumerator 	nsPresContext.cpp:2503
3 	libmozglue.dylib 	arena_malloc 	jemalloc.c:1684
4 	libmozglue.dylib 	je_malloc 	jemalloc.c:4207
5 	XUL 	PL_DHashTableEnumerate 	pldhash.cpp:715
6 	XUL 	XUL@0x2002cf 	
7 	XUL 	nsRootPresContext::GetPluginGeometryUpdates 	
8 	libsystem_c.dylib 	libsystem_c.dylib@0x19865 	
9 	AppKit 	AppKit@0x97efbf 	
10 	libsystem_c.dylib 	libsystem_c.dylib@0x1a174 	
11 	AppKit 	AppKit@0x97efbf 	
12 	Foundation 	Foundation@0x47601 	
13 	AppKit 	AppKit@0x187c49 	
14 	CoreGraphics 	CoreGraphics@0x5479d1 	
15 	AppKit 	AppKit@0x982a6e 	
16 	CoreFoundation 	CoreFoundation@0x351c0 	
17 	CoreFoundation 	CoreFoundation@0xf8e7 	
18 	CoreFoundation 	CoreFoundation@0x2abc8 	
19 	CoreFoundation 	CoreFoundation@0x2114 	
20 	CoreFoundation 	CoreFoundation@0x2114 	
21 	libsystem_c.dylib 	libsystem_c.dylib@0x19d93 	
22 	CoreFoundation 	CoreFoundation@0x34f68

Updated

5 years ago
Keywords: regression
Hardware: All → x86_64
(Assignee)

Comment 1

5 years ago
Appears to be the same cause as bug 781265
Assignee: nobody → jschoenick
Blocks: 745030
Status: NEW → ASSIGNED
tracking-firefox17: --- → ?
Component: Layout → DOM
Depends on: 781265
OS: Mac OS X → All
Hardware: x86_64 → All
tracking-firefox17: ? → +
(Assignee)

Comment 2

5 years ago
Should be solved by bug 781265
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 781265

Updated

5 years ago
No longer depends on: 781265

Updated

5 years ago
Depends on: 781265

Updated

5 years ago
No longer depends on: 781265

Updated

5 years ago
status-firefox17: --- → fixed
You need to log in before you can comment on or make changes to this bug.