Last Comment Bug 782387 - Blank SVG rendering, after clicking a link to a <view> fragment and then navigating back
: Blank SVG rendering, after clicking a link to a <view> fragment and then navi...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: x86_64 Linux
: -- normal with 1 vote (vote)
: mozilla17
Assigned To: Robert Longson
:
Mentors:
http://www.w3.org/Graphics/SVG/Test/2...
Depends on: 512525
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 12:28 PDT by Daniel Holbert [:dholbert]
Modified: 2013-02-23 10:20 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (5.96 KB, patch)
2012-08-14 06:00 PDT, Robert Longson
dholbert: review+
Details | Diff | Review

Description Daniel Holbert [:dholbert] 2012-08-13 12:28:18 PDT
STR:
 1. Visit http://www.w3.org/Graphics/SVG/Test/20011026/linking-view-BE-04.svg

 2. Click "Go to Ellipse"
    --> (rendering changes to just show the blue ellipse)

 3. Navigate back a page (Click Firefox's back button, or press Alt + LeftArrow)

ACTUAL RESULTS: Blank page
EXPECTED RESULTS: original rendering, with multiple shapes visible

Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/17.0 Firefox/17.0
Built from http://hg.mozilla.org/mozilla-central/rev/f89feda9d997
Comment 1 Robert Longson 2012-08-14 06:00:33 PDT
Created attachment 651733 [details] [diff] [review]
patch
Comment 2 Robert Longson 2012-08-14 06:16:52 PDT
There is no viewbox to start with so when we save it we save 0 0 0 0 as the viewbox coordinates since we save whether or not there is a viewbox. We then restore this as the viewbox.
Comment 3 Robert Longson 2012-08-15 02:26:08 PDT
Try: https://tbpl.mozilla.org/?tree=Try&rev=99e442108e9b
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-08-15 18:47:12 PDT
https://hg.mozilla.org/mozilla-central/rev/b56234cc76ff

Note You need to log in before you can comment on or make changes to this bug.