Last Comment Bug 782391 - device storage - Watch should also go through the permission prompt.
: device storage - Watch should also go through the permission prompt.
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla17
Assigned To: Doug Turner (:dougt)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 12:40 PDT by Doug Turner (:dougt)
Modified: 2012-08-18 09:05 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v.1 (2.46 KB, patch)
2012-08-13 12:41 PDT, Doug Turner (:dougt)
jonas: review+
Details | Diff | Splinter Review

Description Doug Turner (:dougt) 2012-08-13 12:40:24 PDT
We were not checking to the result of Allow().  Instead, we always sent back watch state changes.
Comment 1 Doug Turner (:dougt) 2012-08-13 12:41:35 PDT
Created attachment 651509 [details] [diff] [review]
patch v.1
Comment 2 Jonas Sicking (:sicking) PTO Until July 5th 2012-08-13 16:24:06 PDT
Comment on attachment 651509 [details] [diff] [review]
patch v.1

Review of attachment 651509 [details] [diff] [review]:
-----------------------------------------------------------------

Shouldn't we also trigger the prompt when someone registers as an event listener?
Comment 3 Doug Turner (:dougt) 2012-08-13 16:56:16 PDT
yup, that happens now in nsDOMDeviceStorage::AddEventListener().  The problem was we'd prompt and never care about what the result was -- we'd just went ahead and send the change event to all listeners.
Comment 4 Jonas Sicking (:sicking) PTO Until July 5th 2012-08-14 15:30:55 PDT
Comment on attachment 651509 [details] [diff] [review]
patch v.1

Review of attachment 651509 [details] [diff] [review]:
-----------------------------------------------------------------

Ok. Please make sure that the prompt also happens when the onchange property is set, rather than when addEventListener is called.
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-08-18 04:25:39 PDT
https://hg.mozilla.org/mozilla-central/rev/13efbdf35a8b
Comment 7 :Ms2ger (⌚ UTC+1/+2) 2012-08-18 09:05:42 PDT
Tabs :(

Note You need to log in before you can comment on or make changes to this bug.