Last Comment Bug 782416 - [Azure] convert gfx::2d from NULL to nullptr
: [Azure] convert gfx::2d from NULL to nullptr
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: 15 Branch
: All All
: -- normal (vote)
: mozilla17
Assigned To: Joe Drew (not getting mail)
:
Mentors:
Depends on: 781943
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 14:09 PDT by Nick Cameron [:nrc]
Modified: 2012-08-16 06:19 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
do it (125.84 KB, patch)
2012-08-14 10:59 PDT, Joe Drew (not getting mail)
bas: review+
Details | Diff | Review
put nullptr somewhere that works (3.10 KB, patch)
2012-08-15 12:24 PDT, Joe Drew (not getting mail)
ncameron: review+
Details | Diff | Review

Description Nick Cameron [:nrc] 2012-08-13 14:09:03 PDT

    
Comment 1 Joe Drew (not getting mail) 2012-08-14 10:59:17 PDT
Created attachment 651830 [details] [diff] [review]
do it
Comment 2 Bas Schouten (:bas.schouten) 2012-08-14 11:03:43 PDT
Comment on attachment 651830 [details] [diff] [review]
do it

Review of attachment 651830 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/2d/gfx2d.vcxproj
@@ +117,5 @@
>    </ItemGroup>
>    <Import Project="$(VCTargetsPath)\Microsoft.Cpp.targets" />
>    <ImportGroup Label="ExtensionTargets">
>    </ImportGroup>
> +</Project>

Not sure we need this change :) Saving the project in MSVC again might overwrite it!
Comment 3 Joe Drew (not getting mail) 2012-08-15 09:35:20 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/98d2c24ce932
Comment 4 Joe Drew (not getting mail) 2012-08-15 09:52:49 PDT
backed out because I am a moron who doesn't know how to test his code 
https://hg.mozilla.org/integration/mozilla-inbound/rev/6ce9bc206a7d
Comment 5 Joe Drew (not getting mail) 2012-08-15 12:24:17 PDT
Created attachment 652174 [details] [diff] [review]
put nullptr somewhere that works

Turns out that a bunch of 2d didn't support nullptr with only the previous patch. This patch fixes that.
Comment 6 Nick Cameron [:nrc] 2012-08-15 12:36:10 PDT
Comment on attachment 652174 [details] [diff] [review]
put nullptr somewhere that works

Review of attachment 652174 [details] [diff] [review]:
-----------------------------------------------------------------

looks good

::: gfx/2d/2D.h
@@ +5,5 @@
>  
>  #ifndef _MOZILLA_GFX_2D_H
>  #define _MOZILLA_GFX_2D_H
>  
> +#include "Types.h"

I don't think you need this include, but if you _want_ it, then it is fine
Comment 7 Joe Drew (not getting mail) 2012-08-15 12:49:51 PDT
I want it!

Note You need to log in before you can comment on or make changes to this bug.