If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

when fullscreen, text selection shouldn't trigger

RESOLVED DUPLICATE of bug 782008

Status

()

Firefox for Android
Text Selection
RESOLVED DUPLICATE of bug 782008
5 years ago
5 years ago

People

(Reporter: vlad, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

If I have a canvas element fullscreen, and then long-press on the screen, I get the text selection carets overlaid and selecting some text that's not visible (it's on the page before the element became fullscreen).  It should really only consider elements that are fullscreen and their children for selection.

Comment 1

5 years ago
This looks like the same problem as bug 782008, since the same long tap listener that shows context menus is what decides to start text selection. It seems like the solution here is that we should be bailing in there if we're in fullscreen mode.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 782008
You need to log in before you can comment on or make changes to this bug.