Closed Bug 782551 Opened 7 years ago Closed 2 months ago

Drop dd text-indent quirk

Categories

(Core :: CSS Parsing and Computation, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: zcorpan, Assigned: emilio)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Bug 5119 should be reverted. The HTML spec deliberately omits this quirk. Opera and WebKit don't have it, and possibly IE10's non-compat-view quirks mode doesn't have it, either (I haven't checked). Opera does not plan on implementing this quirk.

[[
dd { margin-left: 40px; } /* LTR-specific: use 'margin-right' for rtl elements */
]]
http://www.whatwg.org/specs/web-apps/current-work/multipage/rendering.html#lists

We should probably do this; this can cause performance problems, and if no one else has the quirk, we really shouldn't either, right?

So we're talking about these two rules right?

Sure, I agree that if nobody else does it, we shouldn't either... We should probably also revert bug 8749 while we're at it. Other browsers don't seem to have that quirk either.

Assignee: nobody → emilio
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b1133e4b7e95
Remove two quirks that other browsers don't have. r=bzbarsky
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/18459 for changes under testing/web-platform/tests
Upstream web-platform-tests status checks passed, PR will merge once commit reaches central.
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Duplicate of this bug: 1571313
You need to log in before you can comment on or make changes to this bug.