Last Comment Bug 782614 - Fix still more abuse of nsresult (rdf/, xpcom/)
: Fix still more abuse of nsresult (rdf/, xpcom/)
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: All All
: -- minor (vote)
: mozilla17
Assigned To: :Aryeh Gregor (away until August 15)
:
Mentors:
Depends on:
Blocks: nsresult-enum-class
  Show dependency treegraph
 
Reported: 2012-08-14 05:46 PDT by :Aryeh Gregor (away until August 15)
Modified: 2012-08-19 11:24 PDT (History)
1 user (show)
ayg: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Don't return nsresult from main() (rdf/) (5.39 KB, patch)
2012-08-14 05:47 PDT, :Aryeh Gregor (away until August 15)
benjamin: review+
Details | Diff | Review
Don't return nsresult from main() (xpcom/) (5.36 KB, patch)
2012-08-14 05:47 PDT, :Aryeh Gregor (away until August 15)
benjamin: review+
Details | Diff | Review

Description :Aryeh Gregor (away until August 15) 2012-08-14 05:46:23 PDT

    
Comment 1 :Aryeh Gregor (away until August 15) 2012-08-14 05:47:04 PDT
Created attachment 651723 [details] [diff] [review]
Don't return nsresult from main() (rdf/)
Comment 2 :Aryeh Gregor (away until August 15) 2012-08-14 05:47:48 PDT
Created attachment 651724 [details] [diff] [review]
Don't return nsresult from main() (xpcom/)
Comment 3 Benjamin Smedberg [:bsmedberg] 2012-08-17 09:29:49 PDT
Comment on attachment 651724 [details] [diff] [review]
Don't return nsresult from main() (xpcom/)

In the very last hunk, please just return "2" instead of returning NS_ERROR_FAILURE as main() return code. r=me with that change.
Comment 4 :Aryeh Gregor (away until August 15) 2012-08-19 01:30:42 PDT
Green try except for Windows: https://tbpl.mozilla.org/?tree=Try&rev=fc3eb12e62f4  Windows isn't included because I'm trying to fix Windows build errors in other patches in the series, but it shouldn't behave any differently on Windows.

https://hg.mozilla.org/integration/mozilla-inbound/rev/e4210bdcf836
https://hg.mozilla.org/integration/mozilla-inbound/rev/84bf19883685

(In reply to Benjamin Smedberg  [:bsmedberg] from comment #3)
> In the very last hunk, please just return "2" instead of returning
> NS_ERROR_FAILURE as main() return code. r=me with that change.

Oops, that was a mistake.  Thanks for catching it!

Note You need to log in before you can comment on or make changes to this bug.