A lot of mozStorage threads never finished

RESOLVED WORKSFORME

Status

()

Toolkit
Storage
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: jhorak, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
A lot of mozStorage threads in this backtrace never finished:
https://bugzilla.redhat.com/attachment.cgi?id=603844
I cannot reproduce on my own setup but reporter should only have lightning addon installed.

On the other hand I see about 6 mozStorage threads in my running instance of Thunderbird. Should these threads remain persistent? When calling 'finalize' to statement approx 2-3 references to mAsyncExecutionThread still remain, so object is not released and thread finished.

Reference bug: https://bugzilla.redhat.com/show_bug.cgi?id=805961
Upstream bug has been closed and as noted in https://bugzilla.redhat.com/show_bug.cgi?id=805961#c17 it's not clear that the threads in question are mozStorage threads.  It *is* expected that async threads will persist until explicitly shutdown (at least until bug 722181) is implemented, but that also means the leaked threads can't be mozStorage threads unless some code is opening multiple async db's and not closing them and retaining the reference.  I can speak to the Thunderbird global database to say it's not responsible, and I would generally point fingers at lightning on that bug unless the problem was that a preference was set to enable IMAP to use more than 5 connections at a time, etc.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.