Last Comment Bug 782782 - Assertion failure: allocated(), at ../../gc/Heap.h:497 or Crash [@ js::gc::Arena::isAligned]
: Assertion failure: allocated(), at ../../gc/Heap.h:497 or Crash [@ js::gc::Ar...
Status: RESOLVED FIXED
[js:p2]
: assertion, crash, testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 Linux
: -- critical (vote)
: mozilla17
Assigned To: Bill McCloskey (:billm)
:
:
Mentors:
Depends on: 753283
Blocks: langfuzz 781393
  Show dependency treegraph
 
Reported: 2012-08-14 14:17 PDT by Bill McCloskey (:billm)
Modified: 2012-09-13 12:41 PDT (History)
9 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (834 bytes, patch)
2012-08-14 14:17 PDT, Bill McCloskey (:billm)
bhackett1024: review+
Details | Diff | Splinter Review

Description Bill McCloskey (:billm) 2012-08-14 14:17:07 PDT
Created attachment 651885 [details] [diff] [review]
patch

+++ This bug was initially created as a clone of Bug #753283 +++

Somehow when fixing this bug I failed to fix the non-gcc path as well. This moves MaybeVerifyBarriers from before to after the op is done, just as was done in bug 753283.
Comment 2 Ryan VanderMeulen [:RyanVM] 2012-08-15 18:44:56 PDT
https://hg.mozilla.org/mozilla-central/rev/fc50fe61fd71
Comment 3 Bill McCloskey (:billm) 2012-08-19 15:39:14 PDT
Landed this on Aurora because it was needed for bug 781393.
https://hg.mozilla.org/releases/mozilla-aurora/rev/95a9ef9dfc3d

This change only affects DEBUG builds, and it was only needed to appease some tests.

Note You need to log in before you can comment on or make changes to this bug.