Last Comment Bug 782820 - typos in gclicommands.properties
: typos in gclicommands.properties
Status: RESOLVED FIXED
[fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Console (show other bugs)
: 18 Branch
: All All
: -- trivial (vote)
: Firefox 17
Assigned To: John Engler
:
: Brian Grinstead [:bgrins]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 15:31 PDT by Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout)
Modified: 2012-08-27 21:40 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Changes made as suggested. (3.27 KB, patch)
2012-08-16 00:18 PDT, John Engler
no flags Details | Diff | Splinter Review
Further spelling/grammar corrections (9.91 KB, patch)
2012-08-21 22:12 PDT, John Engler
jwalker: review+
Details | Diff | Splinter Review

Description Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2012-08-14 15:31:47 PDT
Replace "it's" with "its":

cookieSetManual=Set a cookie by specifying a key name, it's value and optionally one or more of the following attributes: expires (max-age in seconds or the expires date in GMTString format), path, domain, secure

The following two descriptions should contain a "that", but I could be wrong (it sounds wrong to a non-native speaker like me):

# LOCALIZATION NOTE (addonAlreadyEnabled) Used in the output of the
# 'addon enable' command when an attempt is made to enable an addon is already
# enabled.

# LOCALIZATION NOTE (addonAlreadyDisabled) Used in the output of the
# 'addon disable' command when an attempt is made to disable an addon is already
# disabled.
Comment 1 John Engler 2012-08-14 23:56:36 PDT
Hi,
  If this is not already assigned, I will happily take it as my first submit.
Comment 2 Ekanan Ketunuti 2012-08-15 04:32:46 PDT
> If this is not already assigned, I will happily take it as my first submit.
Sure.
Comment 3 John Engler 2012-08-16 00:18:48 PDT
Created attachment 652342 [details] [diff] [review]
Changes made as suggested.
Comment 4 John Engler 2012-08-17 16:15:29 PDT
Also, I noticed that there are other inconsistencies within the gclicommands.properties file. Should I fix them and re-submit a patch under this bug or create a new bug?
Comment 5 Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2012-08-18 03:55:09 PDT
You can also fix these issues in this bug.
Comment 6 John Engler 2012-08-18 18:46:45 PDT
Thanks. Are there official guidelines one how the gclicommands should be structured? For example, when to use a period at the end of a sentence, etc?

Also, when referencing the document object, should it be capitalized? inspectNodeManual uses "Document.querySelector" but the actual command would be "document.querySelector". 

(In reply to Archaeopteryx [:aryx] from comment #5)
> You can also fix these issues in this bug.
Comment 7 Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2012-08-19 10:42:40 PDT
> Thanks. Are there official guidelines one how the gclicommands should be
> structured? For example, when to use a period at the end of a sentence, etc?
I leave the gclicommands to the Style Editor owner, period at the end usually mean "launches something which requires user input" (CCing l10n for linking the documentation)

> Also, when referencing the document object, should it be capitalized?
> inspectNodeManual uses "Document.querySelector" but the actual command would
> be "document.querySelector". 
Yes, this should be changed to prevent confusion for people not being familiar with |document|. You will need to update the entity name because the meaning changes and the localizations should pick this up.
Comment 8 John Engler 2012-08-21 22:12:03 PDT
Created attachment 654097 [details] [diff] [review]
Further spelling/grammar corrections
Comment 9 Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2012-08-22 03:10:43 PDT
Pike: This is in devtools, should all entity names be changed because some locales don't translate devtools or is there any other possibility to port the changes to theses localizations?
Comment 10 Axel Hecht [:Pike] 2012-08-22 04:59:12 PDT
Some of these are borderline, so I've poked at mxr a bit to see if they're a problem.

The beauty vs pretty is mostly solved in the translations, the Javascript vs JavaScript isn't. The Document shows up about as often as document does.

I think we shouldn't change the keys, and just post in .l10n about the fixes.
Comment 11 John Engler 2012-08-22 23:43:43 PDT
Is there anything I can (or need to) do to help?

(In reply to Axel Hecht [:Pike] from comment #10)
> Some of these are borderline, so I've poked at mxr a bit to see if they're a
> problem.
> 
> The beauty vs pretty is mostly solved in the translations, the Javascript vs
> JavaScript isn't. The Document shows up about as often as document does.
> 
> I think we shouldn't change the keys, and just post in .l10n about the fixes.
Comment 12 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-08-24 11:51:30 PDT
Comment on attachment 654097 [details] [diff] [review]
Further spelling/grammar corrections

Review of attachment 654097 [details] [diff] [review]:
-----------------------------------------------------------------

Many thanks.
Comment 13 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-08-24 22:57:32 PDT
https://tbpl.mozilla.org/?tree=Fx-Team&rev=bbd267f16fc7
Comment 14 Dave Camp (:dcamp) 2012-08-25 17:03:42 PDT
https://hg.mozilla.org/mozilla-central/rev/76b7f323b8f3
Comment 15 Axel Hecht [:Pike] 2012-08-26 10:19:14 PDT
(In reply to John Engler from comment #11)
> Is there anything I can (or need to) do to help?
> 

Send a post to mozilla.dev.l10n? Thanks.
Comment 16 John Engler 2012-08-27 21:40:53 PDT
(In reply to Axel Hecht [:Pike] from comment #15)
> (In reply to John Engler from comment #11)
> > Is there anything I can (or need to) do to help?
> > 
> 
> Send a post to mozilla.dev.l10n? Thanks.

Post sent. Thank you for everyone's help. :)

Note You need to log in before you can comment on or make changes to this bug.