Last Comment Bug 782825 - Disable bug 716014 for Firefox 15
: Disable bug 716014 for Firefox 15
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: [PTO to Dec5] Bill McCloskey (:billm)
: general
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks: 719114
  Show dependency treegraph
 
Reported: 2012-08-14 15:44 PDT by [PTO to Dec5] Bill McCloskey (:billm)
Modified: 2012-08-27 17:46 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed


Attachments
patch (1.13 KB, patch)
2012-08-14 15:44 PDT, [PTO to Dec5] Bill McCloskey (:billm)
dmandelin: review+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description [PTO to Dec5] Bill McCloskey (:billm) 2012-08-14 15:44:28 PDT
Created attachment 651921 [details] [diff] [review]
patch

Bug 719114 comment 35 has more discussion of this. I'm uncertain whether this would reduce crash volume. However, I think the risk of the doing extra compartment GCs probably outweighs the rewards, which I think are mostly for people with many tabs open.
Comment 1 [PTO to Dec5] Bill McCloskey (:billm) 2012-08-14 16:25:49 PDT
Comment on attachment 651921 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 716014
User impact if declined: Possible increase in GC crashes.
Testing completed (on m-c, etc.): On m-c and aurora.
Risk to taking this patch (and alternatives if risky): Low, since this was disabled through part of aurora.
String or UUID changes made by this patch: None
Comment 2 [PTO to Dec5] Bill McCloskey (:billm) 2012-08-14 16:31:43 PDT
https://hg.mozilla.org/releases/mozilla-beta/rev/65cd4f678ab0
Comment 3 Alex Keybl [:akeybl] 2012-08-27 12:55:29 PDT
(In reply to Bill McCloskey (:billm) from comment #2)
> https://hg.mozilla.org/releases/mozilla-beta/rev/65cd4f678ab0

Do we want to do the same for Beta 16?
Comment 4 [PTO to Dec5] Bill McCloskey (:billm) 2012-08-27 13:30:18 PDT
(In reply to Alex Keybl [:akeybl] from comment #3)
> (In reply to Bill McCloskey (:billm) from comment #2)
> > https://hg.mozilla.org/releases/mozilla-beta/rev/65cd4f678ab0
> 
> Do we want to do the same for Beta 16?

It's already disabled in everything beyond 15.

Note You need to log in before you can comment on or make changes to this bug.