Last Comment Bug 782869 - IonMonkey: Crash during WebGL tests on Mochitest-1
: IonMonkey: Crash during WebGL tests on Mochitest-1
Status: RESOLVED FIXED
[ion:p1]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Eric Faust [:efaust]
:
Mentors:
https://tbpl.mozilla.org/php/getParse...
Depends on:
Blocks: IonGreen
  Show dependency treegraph
 
Reported: 2012-08-14 19:27 PDT by David Anderson [:dvander]
Modified: 2012-08-15 02:57 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix (8.78 KB, patch)
2012-08-14 23:39 PDT, Eric Faust [:efaust]
dvander: review+
Details | Diff | Review

Description David Anderson [:dvander] 2012-08-14 19:27:24 PDT
PROCESS-CRASH | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | application crashed (minidump found)

Stack makes it look like some bogus pointer is being treated as a GC object. It's not clear what is causing this yet.
Comment 1 Eric Faust [:efaust] 2012-08-14 23:39:37 PDT
Created attachment 652019 [details] [diff] [review]
Fix

The problem was that visitCallDOMNative was generating jitcode that passed the address of a value containing a JSObject into a function that expected a HandleObject.
Comment 2 Eric Faust [:efaust] 2012-08-15 02:57:15 PDT
https://hg.mozilla.org/projects/ionmonkey/rev/e7751b77a660

Note You need to log in before you can comment on or make changes to this bug.