Last Comment Bug 782871 - Move TreeContext and related things into the Parser module
: Move TreeContext and related things into the Parser module
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla17
Assigned To: Nicholas Nethercote [:njn] (on vacation until July 11)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-14 19:43 PDT by Nicholas Nethercote [:njn] (on vacation until July 11)
Modified: 2012-08-21 06:29 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Move TreeContext and related things into the Parser module. (26.83 KB, patch)
2012-08-14 19:43 PDT, Nicholas Nethercote [:njn] (on vacation until July 11)
no flags Details | Diff | Review
Rename the |TreeContext| module as |SharedContext|. (6.78 KB, patch)
2012-08-14 19:44 PDT, Nicholas Nethercote [:njn] (on vacation until July 11)
no flags Details | Diff | Review
Move TreeContext and related things into the Parser module. (46.47 KB, patch)
2012-08-16 22:05 PDT, Nicholas Nethercote [:njn] (on vacation until July 11)
jorendorff: review+
Details | Diff | Review
Rename the |TreeContext| module as |SharedContext|. (7.63 KB, patch)
2012-08-16 22:06 PDT, Nicholas Nethercote [:njn] (on vacation until July 11)
jorendorff: review+
Details | Diff | Review

Description Nicholas Nethercote [:njn] (on vacation until July 11) 2012-08-14 19:43:17 PDT
TreeContext can be moved into the Parser module, and the TreeContext module
can then be renamed.
Comment 1 Nicholas Nethercote [:njn] (on vacation until July 11) 2012-08-14 19:43:38 PDT
Created attachment 651977 [details] [diff] [review]
Move TreeContext and related things into the Parser module.

This patch moves TreeContext, frontend::GenerateBlockId and StmtInfoTC out
of the |TreeContext| module into the |Parser| module.  This is good because
they're all things that are only needed by the Parser (i.e. not by the
ByteCodeEmitter).

This results in the removal of frontend/TreeContext.cpp and the addition of
frontend/Parser-inl.h.

I also removed some unnecessary #include statements.
Comment 2 Nicholas Nethercote [:njn] (on vacation until July 11) 2012-08-14 19:44:39 PDT
Created attachment 651978 [details] [diff] [review]
Rename the |TreeContext| module as |SharedContext|.

This patch renames the |TreeContext| module as |SharedContext|, which better
reflects its contents.
Comment 3 Nicholas Nethercote [:njn] (on vacation until July 11) 2012-08-14 19:47:27 PDT
BTW, this will totally bit-rot the patches in bug 770865, but they're already rotten so it's no great loss, and they'll end up being smaller as a result of the changes in this bug.  I'm happy to take over that bug.
Comment 4 Luke Wagner [:luke] 2012-08-15 10:41:34 PDT
I'd be very appreciative if this could land after bug 775323.
Comment 5 Nicholas Nethercote [:njn] (on vacation until July 11) 2012-08-16 22:05:43 PDT
Created attachment 652674 [details] [diff] [review]
Move TreeContext and related things into the Parser module.

Updated for Luke's recent changes.
Comment 6 Nicholas Nethercote [:njn] (on vacation until July 11) 2012-08-16 22:06:15 PDT
Created attachment 652675 [details] [diff] [review]
Rename the |TreeContext| module as |SharedContext|.

Updated for Luke's recent changes.

Note You need to log in before you can comment on or make changes to this bug.