Closed Bug 782877 Opened 7 years ago Closed 7 years ago

Intermittent browser_dbg_bfcache.js | uncaught JS exception - TypeError: element is undefined at debugger-controller.js:1275

Categories

(DevTools :: Debugger, defect, P1)

15 Branch
x86_64
macOS
defect

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 18

People

(Reporter: philor, Assigned: vporof)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #752860 +++

https://tbpl.mozilla.org/php/getParsedLog.php?id=14385826&tree=Firefox
Rev4 MacOSX Snow Leopard 10.6 mozilla-central opt test mochitest-other on 2012-08-14 18:57:01 PDT for push 86ee4deea55b
slave: talos-r4-snow-018

TEST-START | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_bfcache.js
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_bfcache.js | Console message: [JavaScript Warning: "Use of Mutation Events is deprecated. Use MutationObserver instead." {file: "chrome://browser/content/orion.js" line: 3408}]
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_bfcache.js | Console message: [JavaScript Warning: "Use of Mutation Events is deprecated. Use MutationObserver instead." {file: "chrome://browser/content/orion.js" line: 3408}]
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_bfcache.js | Found the expected number of scripts.
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_bfcache.js | Found the first script label.
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_bfcache.js | Found the second script label.
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_bfcache.js | Console message: [JavaScript Warning: "Use of attributes' specified attribute is deprecated. It always returns true." {file: "chrome://browser/content/orion.js" line: 6341}]
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_bfcache.js | Console message: [JavaScript Warning: "Use of removeAttributeNode() is deprecated. Use removeAttribute() instead." {file: "chrome://browser/content/orion.js" line: 6342}]
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_bfcache.js | Successfully reattached to the tab again.
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_bfcache.js | Found the expected number of scripts.
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_bfcache.js | Found the single script label.
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_bfcache.js | Going back.
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_bfcache.js | Successfully reattached to the tab after going back.
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_bfcache.js | Found the expected number of scripts.
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_bfcache.js | Found the first script label.
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_bfcache.js | Found the second script label.
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_bfcache.js | Going forward.
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_bfcache.js | an unexpected uncaught JS exception reported through window.onerror - TypeError: element is undefined at chrome://browser/content/debugger-controller.js:1275
Stack trace:
    JS frame :: chrome://mochikit/content/tests/SimpleTest/SimpleTest.js :: simpletestOnerror :: line 994
    native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0

TEST-INFO | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_bfcache.js | Console message: [JavaScript Error: "TypeError: element is undefined" {file: "chrome://browser/content/debugger-controller.js" line: 1275}]
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_bfcache.js | Successfully reattached to the tab after going forward.
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_bfcache.js | Found the expected number of scripts.
TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_bfcache.js | Found the single script label.
INFO TEST-END | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_bfcache.js | finished in 1115ms
It looks like this happens when a source load takes longer than the test deciding to resume.  I suspect the pause token stuff fitzgen is working on is going to fix this.
Summary: Intermittent browser_dbg_bfcache.js | an unexpected uncaught JS exception reported through window.onerror - TypeError: element is undefined at chrome://browser/content/debugger-controller.js:1275 → Intermittent browser_dbg_bfcache.js | uncaught JS exception - TypeError: element is undefined at debugger-controller.js:1275
Became extremely frequent around the 25-27th, now one of our top oranges.

Could we ignoreAllUncaughtExceptions() this until it is fixed please?
Priority: P3 → P1
Looking at the timeframe, caused by bug 790650.
Blocks: 790650
I've backed out bug 790650 for now, so this should stop once it merges around.
Attached patch v1Splinter Review
From the patch:
+    // Tab navigated before we got a chance to finish loading and display the
+    // source. The outcome is that the expected source is not present anymore
+    // in the scripts container, hence the original script object coming from
+    // the active thread no longer exists. There's really nothing that needs
+    // to be done in this case, nor something that can be currently avoided.

I think this is the correct reasoning, however I don't have any explanation on why this orange started being so incredibly chatty the last 3 days.
Assignee: nobody → vporof
Status: NEW → ASSIGNED
Attachment #666528 - Flags: review?(rcampbell)
Attachment #666528 - Flags: review?(rcampbell) → review+
No longer blocks: 790650
https://hg.mozilla.org/integration/fx-team/rev/a2214e8900c0
Whiteboard: [orange] → [orange][fixed-in-fx-team]
Thank you :-D
https://hg.mozilla.org/mozilla-central/rev/a2214e8900c0
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [orange][fixed-in-fx-team] → [orange]
Target Milestone: --- → Firefox 18
Inbound needs a merge.
(In reply to Victor Porof [:vp] from comment #227)
> Inbound needs a merge.

It's had one, the test runs are just catching up :-)
Whiteboard: [orange]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.