Closed Bug 782886 Opened 7 years ago Closed 7 years ago

crash in nsGfxScrollFrameInner::AsyncScroll::InitTimingFunction

Categories

(Core :: Layout, defect, critical)

16 Branch
x86_64
macOS
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox15 --- unaffected
firefox16 - unaffected
firefox17 --- unaffected

People

(Reporter: scoobidiver, Unassigned)

Details

(Keywords: crash, regression, topcrash)

Crash Data

It first appeared in 16.0a2/20120814 and is currently #1 top crasher on Mac OS X in 16.0a2.

The regression range is:
http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=6de83f12aa1d&tochange=1b8af79d5194

Signature 	nsGfxScrollFrameInner::AsyncScroll::InitTimingFunction More Reports Search
UUID	a4a99772-ba28-4817-a4c9-a01152120815
Date Processed	2012-08-15 06:27:32
Uptime	6475
Last Crash	1.8 hours before submission
Install Age	3.7 hours since version was first installed.
Install Time	2012-08-15 02:45:58
Product	Firefox
Version	16.0a2
Build ID	20120814042009
Release Channel	aurora
OS	Mac OS X
OS Version	10.6.8 10K549
Build Architecture	amd64
Build Architecture Info	family 6 model 37 stepping 5
Crash Reason	EXC_BAD_ACCESS / 0x0000000d
Crash Address	0x7ffc
App Notes 	
AdapterVendorID: 0x1002, AdapterDeviceID: 0x9488GL Context? GL Context+ GL Layers? GL Layers+ 
EMCheckCompatibility	True
Adapter Vendor ID	0x1002
Adapter Device ID	0x9488

Frame 	Module 	Signature 	Source
0 	XUL 	nsGfxScrollFrameInner::AsyncScroll::InitTimingFunction 	nsGfxScrollFrame.cpp:1550
1 	XUL 	nsGfxScrollFrameInner::ScrollToWithOrigin 	nsGfxScrollFrame.cpp:1512
2 	XUL 	nsGfxScrollFrameInner::ScrollBy 	nsGfxScrollFrame.cpp:2509
3 	XUL 	nsHTMLScrollFrame::ScrollBy 	nsGfxScrollFrame.h:481
4 	XUL 	PresShell::ScrollCharacter 	nsPresShell.cpp:2167
5 	XUL 	nsSelectMoveScrollCommand::DoCommand 	nsGlobalWindowCommands.cpp:271
6 	XUL 	nsControllerCommandTable::DoCommand 	nsControllerCommandTable.cpp:158
7 	XUL 	nsBaseCommandController::DoCommand 	nsBaseCommandController.cpp:137
8 	XUL 	nsXBLPrototypeHandler::DispatchXBLCommand 	nsXBLPrototypeHandler.cpp:472
9 	XUL 	nsXBLPrototypeHandler::ExecuteHandler 	nsXBLPrototypeHandler.cpp:221
10 	XUL 	nsXBLWindowKeyHandler::WalkHandlersAndExecute 	nsXBLWindowKeyHandler.cpp:526
11 	XUL 	nsXBLWindowKeyHandler::WalkHandlersInternal 	nsXBLWindowKeyHandler.cpp:438
12 	XUL 	nsXBLWindowKeyHandler::WalkHandlers 	nsXBLWindowKeyHandler.cpp:319
13 	XUL 	nsXBLWindowKeyHandler::HandleEvent 	nsXBLWindowKeyHandler.cpp:365
14 	XUL 	nsEventListenerManager::HandleEventInternal 	nsEventListenerManager.cpp:820
15 	XUL 	nsEventTargetChainItem::HandleEventTargetChain 	nsEventListenerManager.h:143
16 	XUL 	nsEventTargetChainItem::HandleEventTargetChain 	nsEventDispatcher.cpp:371
17 	XUL 	nsEventDispatcher::Dispatch 	nsEventDispatcher.cpp:639
18 	XUL 	PresShell::HandleEventInternal 	nsPresShell.cpp:6449
19 	XUL 	PresShell::HandleEvent 	nsPresShell.cpp:6064
20 	XUL 	PresShell::HandleEvent 	nsPresShell.cpp:5676
21 	XUL 	nsViewManager::DispatchEvent 	nsViewManager.cpp:863
22 	XUL 	HandleEvent 	nsView.cpp:127
23 	XUL 	nsChildView::DispatchEvent 	nsChildView.mm:1486
24 	XUL 	nsChildView::DispatchWindowEvent 	nsChildView.mm:1496
25 	XUL 	mozilla::widget::TextInputHandlerBase::DispatchEvent 	TextInputHandler.mm:3782
26 	XUL 	mozilla::widget::TextInputHandler::HandleKeyDownEvent 	TextInputHandler.mm:1366 
...

More reports at:
https://crash-stats.mozilla.com/report/list?signature=nsGfxScrollFrameInner%3A%3AAsyncScroll%3A%3AInitTimingFunction
QA Contact: mozillamarcia.knous
It seems limited to one build. It might be caused by a bustage in the Aurora tree.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.