ABORT: file gecko/ipc/chromium/src/base/pickle.cc, line 200 (Pickle::ReadSize)

RESOLVED DUPLICATE of bug 780219

Status

()

Core
IPC
--
critical
RESOLVED DUPLICATE of bug 780219
6 years ago
5 years ago

People

(Reporter: posidron, Unassigned)

Tracking

(Blocks: 1 bug, {crash})

Trunk
ARM
Gonk (Firefox OS)
crash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 652091 [details]
callstack

This crash occurred during the launch of Firefox on B2G while intercepting the pickle Write|Datatype| functions.

An interception only happened when XRE_GetProcessType() == GeckoProcessType_Content

Seed: 1345038189

Let me know if you need further information.

Updated

5 years ago
Crash Signature: [@ mozalloc_abort(char const* const) | NS_DebugBreak | mozilla::Logger::~Logger()]

Updated

5 years ago
Summary: ABORT: file gecko/ipc/chromium/src/base/pickle.cc, line 200 → ABORT: file gecko/ipc/chromium/src/base/pickle.cc, line 200 (Pickle::ReadSize)

Comment 1

5 years ago
Is there a test case for this?
DCHECK() abort in Pickle::ReadSize(). Duplicate of 780219.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 780219
You need to log in before you can comment on or make changes to this bug.