If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Address string with Cyrillic characters gets malformed

RESOLVED DUPLICATE of bug 775072

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 775072
5 years ago
5 years ago

People

(Reporter: truePlayer701, Unassigned)

Tracking

14 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Open a new tab and type an address with some Russian characters, for example, http://ru.wikipedia.org/wiki/ЧС7 , then press Enter. The address will change to http://ru.wikipedru.wikipedia.org/wiki/%D0%A7%D0%A17 , and a typical "Server not found" page will appear, instead of the correct page being opened.

Maybe this is somehow related to the autocompletion feature.
(Reporter)

Comment 1

5 years ago
Oh, if you copy the address from the above description, it won't work because Cyrillic characters will get replaced by "%D0%A7%D0%A17". You have to type the address to see this bug.
Indeed. this should be fixed in F16 though. See duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 775072
You need to log in before you can comment on or make changes to this bug.