mozilla either crashes or freezes after clicking send mail

VERIFIED INVALID

Status

MailNews Core
Composition
--
critical
VERIFIED INVALID
18 years ago
10 years ago

People

(Reporter: Brian Tarricone, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.3 i686; en-US; rv:0.8.1+) Gecko/20010430
BuildID:    2001043014

immediately after clicking the send button to send a mail message, mozilla
either segfaults or freezes on linux.  in both instances, the 'kill' command is
required, and in the freeze case, windows must be manually destroyed (via some
manual window manager function).  also, there is always one mozilla-bin process
left over that cannot be removed without a system restart (for freeze only;
segfault exits "cleanly").  it seems that the mail is actually sent, but no copy
of the message gets to the Sent folder.

Reproducible: Always
Steps to Reproduce:
1. compose and address a mail message
2. click send
3. BOOM!

Actual Results:  mozilla either segfaults or freezes (permanently).  mail is
sent, but a copy is _not_ written to the Sent folder

Expected Results:  mail sent, copy written to Sent folder, mozilla continues on
its merry way

this has cropped up in builds of the past 3 or 4 days.  before this there was no
problem.

Comment 1

18 years ago
Reporter, I would create a new profile and try again. I just attempted and found
no problems. 

WFM

Moz Build: Linux 2001043014
User Agent: Mozilla/5.0 (X11; U; Linux 2.4.3-20mdk i686; en-US; rv:0.8.1+)
Gecko/20010430
(Reporter)

Comment 2

18 years ago
confirmed - with a fresh profile i have no problems.  as soon as i move my
netscape 4.x mail folders in, i get the crash/freeze problem again.  do i just
have damaged mail folders, or does mozilla have a problem handling ns 4.x mail
files?

Comment 3

18 years ago
Brian, 
uisng the 4-30 linux build, I can not reproduce this.  Can you give me more info:
POP or IMAP?
Is your Copy to Sent folder set for copying msgs to your Sent folder on your POP
or IMAP account?
Were you using this profile in builds just prior to this one with no problem?
Uncheck the box for copying msgs to a [selected] folder when sending and see if
you still have the problem?

(Reporter)

Comment 4

18 years ago
i am using pop (that is my only mail profile).
when i uncheck the box for copying sent messages to the Sent folder, the problem
disappears.

i can guess that there are probably 3 possibilities:
1) mozilla doesn't like mail folders from ns 4.x
2) my mail folder is damaged in some way
3) mozilla has a problem copying sent messages to large folders (>1400 msgs)

just because of my pessimistic nature i tend to assume the 2nd case.

i think it is noteworthy however that i had no problem when using builds of more
than 4 or 5 days ago.  this could be indicative of (2) above as well i guess...
(Reporter)

Comment 5

18 years ago
it seems this was my fault - i had a slightly corrupted mail file.  my files
were located on a fat32 volume.  i had win2k run its disk checker on it,
repaired the file, and now everything seems ok.  sorry if i wasted people's time...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 6

17 years ago
Mark it verified/invalid.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.