Closed Bug 783216 Opened 10 years ago Closed 10 years ago

WebGL FPS is really low in comparison with Chrome

Categories

(Core :: Graphics: CanvasWebGL, defect)

14 Branch
x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 806207

People

(Reporter: teleyinex, Unassigned)

References

()

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120815165828

Steps to reproduce:

Opened http://martin.cyor.eu/benchmark/test.html and run the tests


Actual results:

The FPS start at 30 and then slowly go down until they are around 13

The same page with Chrome reports around 200 FPS which is also "suspicious".


Expected results:

Similar FPS as Chrome or at least do not drop to 10 FPS
I'm using latest nvidia drivers 304.37 with Ubuntu 12.04.
Also tested with latest nightly
My FPS is around 20 with Seamonkey trunk on win7/nvidia 310M
Component: Untriaged → Canvas: WebGL
Product: Firefox → Core
Attached file PERF data
PERF data from Firefox browsing the web site.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
The perf.data file was poorly recorded: it doesn't have any symbol information for Firefox's code (including libxul.so). Since Nightly is built to enable profiling, that suggests that what you profiled wasn't nightly. Also, the perf.data doesn't have call graph information. Please record with

    perf record -f -g -p (PID OF FIREFOX)

once you have your testcase running.
Tried to access the testcase bug the server (martin.cyor.eu) won't reply.

Since you're testing on Linux, you have to know that WebGL performance is currently known to be bad because GL-accelerated compositing is currently disabled. Please go to about:config, set layers.acceleration.force-enabled=true, and restart Firefox, and retry. If this is now fast, we'll know that this bug is a duplicate of bug 594876.
PING martin.cyor.eu (85.25.12.72) 56(84) bytes of data.
^C
--- martin.cyor.eu ping statistics ---
117 packets transmitted, 0 received, 100% packet loss, time 116928ms
You need to log in before you can comment on or make changes to this bug.