dump about:memory-like info on demand

RESOLVED FIXED in Firefox 18

Status

()

Firefox for Android
General
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: gbrown, Assigned: kats)

Tracking

unspecified
Firefox 18
x86
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
When looking at mochitests that cause OOM (see bug 775227 and related), I often see Fennec receive the onLowMemory notification shortly before the tests fail and / or Fennec is killed. Dumping memory information to logcat during onLowMemory might provide useful information about the causes of these failures.
(Reporter)

Comment 1

6 years ago
Note bug 784040 -- might want to do this at the same time / in the same memory observer.
Blocks: 792155
Depends on: 788021
Created attachment 663046 [details] [diff] [review]
Dump memory stats on receiving the org.mozilla.gecko.MEMORY_DUMP intent

This adds a Java -> JS message to dump about:memory stats and exposes it via an intent. Some of this can be axed when bug 788021 lands but I want something in for now so that I can cron a script to run a benchmark.
Attachment #663046 - Flags: review?(snorp)
Attachment #663046 - Flags: review?(snorp) → review+
Renaming the bug in light of https://bugzilla.mozilla.org/show_bug.cgi?id=792155#c1 and what the patch actually does.
Summary: dump about:memory-like info onLowMemory → dump about:memory-like info on demand
Blocks: 792165
https://hg.mozilla.org/mozilla-central/rev/e716df0361db
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18
You need to log in before you can comment on or make changes to this bug.