Closed Bug 783391 Opened 8 years ago Closed 8 years ago

NS_ERROR_FILE_IS_DIRECTORY on mochitest-chrome runs

Categories

(Testing :: Mochitest, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla17

People

(Reporter: myk, Assigned: myk)

References

Details

(Keywords: regression)

Attachments

(1 file)

A change I made to testing/mochitest/tests/SimpleTest/setup.js in bug 770770:

http://hg.mozilla.org/mozilla-central/diff/07b53bdc212a/testing/mochitest/tests/SimpleTest/setup.js

Regressed manual mochitest-chrome runs:

$ make mochitest-chrome TEST_PATH=dom/tests/mochitest/webapps/
...
JavaScript error: chrome://mochikit/content/tests/SimpleTest/MozillaLogger.js, line 90: NS_ERROR_FILE_IS_DIRECTORY: Component returned failure code: 0x8052000d (NS_ERROR_FILE_IS_DIRECTORY) [nsIFileOutputStream.init]

It apparently didn't regress automated runs, though, as my TryServer run didn't exhibit the problem:

https://tbpl.mozilla.org/?tree=Try&rev=5b6a466bf1c2

And it doesn't regress all manual runs.  Fabrice noticed the problem on Linux, and Nick noticed it on Mac.  I see it on Linux, but I don't see it on Mac.  (I'm still waiting for my Windows build to finish.)

I made the change because I noticed (on Windows) that the values in question were arrays with a single string item but were being treated as strings, which happens to work but is a recipe for trouble.

Nevertheless, in my testing today I find that they are strings.  I'm not sure why they were arrays in my earlier testing.  Perhaps I mistook them, or maybe their type changed between when I made the observation and when I landed the patch.

In any case, I think the right thing to do is to simply revert the change.  Here's a patch that does so.
Attachment #652582 - Flags: review?(adw)
Attachment #652582 - Flags: review?(adw) → review+
https://hg.mozilla.org/mozilla-central/rev/e316e0cca3dc
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Component: Mochitest Chrome → Mochitest
You need to log in before you can comment on or make changes to this bug.