"Assertion failure: bi->aliased(),"

RESOLVED FIXED in mozilla17

Status

()

Core
JavaScript Engine
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: gkw, Assigned: luke)

Tracking

(Blocks: 2 bugs, {assertion, regression, testcase})

Trunk
mozilla17
x86
Mac OS X
assertion, regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [jsbugmon:update][fuzzblocker])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 652640 [details]
stack

(function(x, x) {
  eval(x = function() {})
})()

asserts js debug shell on m-c changeset a79132ac2f05 without any CLI arguments at Assertion failure: bi->aliased(),

I think bug 775323 may be the cause here.
Also hitting this, with varying signatures => fuzzblocker.
Blocks: 676763
Whiteboard: [jsbugmon:update][fuzzblocker]
(Reporter)

Comment 2

5 years ago
Actually, bug 767013 may be the cause.

autoBisect shows this is probably related to the following changeset:

The first bad revision is:
changeset:   102515:abc8c217f032
user:        Luke Wagner
date:        Mon Aug 06 07:56:45 2012 -0700
summary:     Bug 767013 - only store aliased variables in scope objects (r=bhackett)
Blocks: 767013
No longer blocks: 775323
(Assignee)

Comment 3

5 years ago
Created attachment 652778 [details] [diff] [review]
fix and test

Thanks!
/me shakes fist at duplicate formal args...
simple fix though
Assignee: general → luke
Status: NEW → ASSIGNED
Attachment #652778 - Flags: review?(dvander)
Attachment #652778 - Flags: review?(dvander) → review+
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/e3be0d046085
https://hg.mozilla.org/mozilla-central/rev/e3be0d046085
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla17
A testcase for this bug was automatically identified at js/src/jit-test/tests/basic/testBug783441.js.
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.